Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

Problem with EVERY driver and r9 280x

Sorry if I come off a little strong, but I am ANGRY. I've had to reinstall my drivers about 5 or 6 times in the last month that i've had this new system. I have 2  r9 280x's and one problem is that GPU 2 runs at 100% with NOTHING happening. Disabling ULPS in the registry works SOMETIMES. If it doesn't then i disable crossfire and try to reenable it but it BLUE SCREENS. this has happened like 3 times. I tried 13.11 beta v4 and 5, i tried 13.10 which i seemed to have no issues with and 13.12 which just did the same stuff, disabling ULPS did nothing,disabling crossfire worked but enabling causes blue screen, im surprised that uninstalling didnt cause a blue screen and cause my computer to stop booting and cause me to do a system restore to fix it like it did before. Seriously, I didnt spend $700 on video cards to spend more time trying to get the bad drivers to work like they are supposed to. Fix the ULPS bug thats been around in the last 10 versions of your driver, I've always been an AMD fan and I always tell people AMD is the way to go, maybe i should just sell my cards to some unsuspecting kid and buy a titan.

0 Replies