Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

[OpenCL] Windows Vista Set up

Before I get shouted at, please note I tried to post this in the OpenCL section but for some reason I am not allowed to start a new topic in there. If a moderator would like to move this post to that section of the forum, then please do so. 


OK, onto my problem


I am trying to learn OpenCL, but I am having some real problems setting up my environment. I have spent the last 2 hours following links and so called guides on how to run my first OpenCL program.

I have update my graphics card drivers to make sure it supports OpenCL (my card is a msi radeon x1550 and I have a really old computer in case you couldn't tell), I downloaded the AMD APP SDK and followed its instructions on how to build/run the first program. But when I do I get the following error:

Note it is the simple "hello world" app that comes with it.

fatal error C1083: Cannot open include file: 'CL/opencl.h'
fatal error C1083: Cannot open include file: 'SDKFile.hpp'

I am using Visual Studio Express 2010 and I just ran the program as it came. I haven't touched a line of code or messed with any of the programs hierarchy. Going by the files instructions, it really should have been a case of hit F5 and go. But I keep getting the above errors.

I even bought the OpenCL PDF to work through but it doesn't cover set up of AMD. They have a nice bit about everything else, just not AMD. 


I can run the precompiled programs that come with the AMD APPS SDK but I can't run the code from inside Visual Studio Express. I have both 2008 and 2010 and both have the same problems.

2 Replies
Journeyman III

[OpenCL] Windows Vista Set up


It seems that there is a problem with your environment variables setup. Check what $ATISTREAMSDK is pointing to. You can do this through MyComputer > Propoerties > Environment settings. (or similar path .. sorry I don't have Vista). 

If this doesn't work .. try replacing $(ATISTREAMSDK) with the actual path which should be something like C:\ProgramFiles\AMD APP\ 

That path will contain the lib\x86 folder and the include\ folder. 

Hope this helps.. 

Journeyman III

[OpenCL] Windows Vista Set up

Hi there

I have since done that, but now have the following error:

1>LINK : fatal error LNK1104: cannot open file 'SDKUtil.lib'


I've added in all of the lib file paths to the program, but I am still getting this error. 


I've tried goggling this but I got a googlewhack which didn't really offer me any useful information . Right now, all I want to do is build and run the HelloCL program you get in the SDK. I've not even touched a line of code...