cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

312227
Journeyman III

opencl multi device radeon hd 57x0 and/or 65x0 in linux

hi,

i am trying to use opencl with multiple GPU devices on linux, but i am only able to work with the first GPU-device within the system - and the CPU, but thats not my problem, i want to use multiple GPU devices. i am using somewhat older cards - i am doing software development for academic purposes, not for real hpc on this system ... so no money available to buy 2 brandnew 79x0 devices ... 😕

the devices are two 5750, one 5770 an one 6570 card.

regardless which pair of these three cards i try to use, i always see only the first device within the system - asrock 870 socket am3 mainboard with 2 pci-e slots.

to test/access these cards i use a small mockup example in c++ - via the fglrx-driver/amdapp sdk - and java (jocl.org).

* my general setting: debian squeeze with backports-org 3.2 kernel

amd-app sdk 2.7

fglrx-12.4 (the recommended vor sdk 2.7) and 12.8 (the current one

* xorg.conf: fresh configuration generated with

aticonfig --adapter=0,1 --initial

* i use opencl version 1.2

* the cards are visible to the system - there are 2 working monitors, one connected to each of the cards and for example the fglrxinfo shows active opengl for both cards ... in this case one 5750 and the 6570 device:

thorp:~$ fglrxinfo

display: :0.0  screen: 0

OpenGL vendor string: Advanced Micro Devices, Inc.

OpenGL renderer string: ATI Radeon HD 5700 Series

OpenGL version string: 4.2.11762 Compatibility Profile Context

display: :0.0  screen: 1

OpenGL vendor string: Advanced Micro Devices, Inc.

OpenGL renderer string: AMD Radeon HD 6570

OpenGL version string: 4.2.11762 Compatibility Profile Context

are there any known problems with opencl and these older cards? does it make sense to buy newer ones or is there a problem with the relative old debian squeeze system? should i use a current ubuntu version for example?

i am thankfull for any hint or link - if this is a rtfm question: sorry, but i am searching the net for answers to this problem since a few days, so i think it shouldn't be a trivial question.

cheers

v.

0 Likes
4 Replies
nou
Exemplar

opencl multi device radeon hd 57x0 and/or 65x0 in linux

do you export DISPLAY=:0 ?

0 Likes
312227
Journeyman III

opencl multi device radeon hd 57x0 and/or 65x0 in linux

hi,

yes - DISPLAY=:0.0 - i am working on this system within X.

cheers

v.

0 Likes
nou
Exemplar

Re: opencl multi device radeon hd 57x0 and/or 65x0 in linux

no. to work with multiple GPU DISPLAY must be DISPLAY=:0 without second zero

0 Likes
312227
Journeyman III

opencl multi device radeon hd 57x0 and/or 65x0 in linux

hey,

woops: you are right - now i am able to use the second GPU-device.

sorry for my "noob" question - i am working with opencl since a rather long time, but always only with one device and therefore never encounterd this problem

cheers

v.

0 Likes