cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

set
Adept I

OpenCL in 15.7 driver still doesn't work

The same bugs that have being reported many months ago are still present in 15.7 driver. (System: Win7 x64, Radeon HD6950.)

First of all not working clEnqueueWriteBufferRect/clEnqueueReadBufferRect until you specify CL_MEM_ALLOC_HOST_PTR on allocation. I'm not going to add specific workarounds to public version of my application just to please AMD drivers – it still has status "not working on AMD".

Second issue is 15.7 driver is again creating temporary files OCL*.tmp in current folder when creating OpenCL context but now not even deleting them! And of course if current folder is not writeable creating OpenCL fails.

Will those issues ever be fixed? What were tester/QC team doing that they didn't notice that driver marked as stable/WHQL adds new file to current folder each times something uses OpenCL?

Tags (1)
3 Replies
dipak
Staff
Staff

Re: OpenCL in 15.7 driver still doesn't work

Just wanted to update you. The clEnqueueWriteBufferRect/clEnqueueReadBufferRect issue has been reported to engg. team and they are working on it. Please keep patience.

Regards,

0 Likes
set
Adept I

Re: OpenCL in 15.7 driver still doesn't work

Thank you. I feared that you've dropped all the work on VLIW architectures and we won't ever see the working implementation since it has been like an year since the problem appeared.

0 Likes
dipak
Staff
Staff

Re: OpenCL in 15.7 driver still doesn't work

Nothing like that. Somehow it skipped during the verification process. I've already reported to engg. team and, as I've come to know, they are treating this issue as a high priority one.

Regards,

0 Likes