cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

hujh
Journeyman III

OpenCL 1.1, sdk v2.6

My GPU is AMD Radeon HD 5570, only OpenCL 1.1 supported. Where can I find amd-app-sdk v2.6, or other sdk supports OpenCL 1.1

Tags (2)
0 Likes
1 Reply
dipak
Staff
Staff

Re: OpenCL 1.1, sdk v2.6

Hi,

You can find some of the older SDKs here.

http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/down...

If you install more recent  compatible driver, I guess, you will be able to use newer SDKs as well. As you know, OpenCL header files support macros to control multiple version of APIs. So, one can select the intended API version compatible with their OpenCL runtime/driver as required. Also, during the clBuildProgram, you  may need to pass -cl-std=CL1.1" to control the CL version according to your targeted device  (for example, currently CL 1.2 is enabled by default).

Regards,

0 Likes