Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Adept III

Massive OpenCL performance drop with Catalyst 11.11

runs at 40% of speed compared to catalyst (11.5-11.10)

Just updated from Catalyst 11.10 to 11.11 and run my OpenCL program (voxel raytracer) now runs 2.5x slower on my 5870 compared to the previous catalyst release! Performance has plumetted from 28M rays/sec down to 12M.

I've updated every single catalyst release since acquiring my gfx card and this is a first. From Catalyst 11.5+ (basically since I started coding OpenCL) the speed has remained constant, apart from 1 or 2% increase each time. Is this a bug? (it has to be surely?!)

I've tried rolling back to 11.10 but the performance still sticks (there must be some files somewhere that aren't being removed)

What's happened? Is this just me?

Windows 7 64bit, ATI 5870.

2 Replies

I have not been able to download 11.11 for my Win 7 64-bit notebook, as the link seems to be fishy (which I indicated on General Forums), but as for reverting drivers...

on Windows it is very hard to revert drivers, because they leave a lot of garbage after themselves. The Catalyst Install Manager could be improved on that part. I suggest you do a system restore to the point where you installed the new driver.

0 Likes seems this massive slowdown was caused by a bug in my code...!

Strangely on Catalyst 11.5-11.10 it never caused any problems whatsoever...suddenly upgrading revealed this bug. I think I may have been writing outside the bounds of a global buffer...but the code worked perfectly with no strange results...

strange? But my fault it was. Hail AMD!