Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Adept II in Linux 16.6 drivers

There is a problem running in the 16.6 drivers on Ubuntu 13.10 64 bit.

./ 143: ./ [[: not found

The solution is in the comments of How to install AMD graphics drivers on Ubuntu - YouTube by Scott Walter:

I think I found the solution.  I'm also on Ubuntu 14.04, attempting to install the fglrx-14.20 and received the exact same error.

First, extract the .run file:
     ./ --extract

Next, cd into the newly created directory
    cd fgrlx-install
    # optionally, run this to preview the line which is causing the error:
    grep -n "\[\["

Now, open in your preferred editor and search for "[[" (without quotes).  Given that we're working with exactly the same version, you should find this on line 143.  Comment out the entire conditional block (lines 143-145).

Finally, run the install script with sudo:
    sudo ./ 14.20 --install
It seems to do something for OpenCL-settings. Could this be fixed in the official download?
3 Replies
Adept II

Bump! Has it been fixed already?


I got this same error when installing.

I also get

"loki_setup: directory: (null)"

It appears to work fine, but not sure why this error pops up in the terminal.


Still broken: Downloaded the latest beta today, and got:

Detected configuration:

Architecture: x86_64 (64-bit)

X Server: X.Org 6.9 or later 64-bit

./ 143: ./ [[: not found

loki_setup: directory: (null)