Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

After installing the rpm via "

sudo rpm -Uvh --nodeps CodeXL*.rpm

as instructed in the Quick Start guide (on Ubuntu 12.10), it looks like a shared library file is missing.

This is what I get when trying to start the app:

jdart@bunny:~/CodeXL-1.1.1537.0/opt/AMD/CodeXL/bin$ ./CodeXL

/home/jdart/CodeXL-1.1.1537.0/opt/AMD/CodeXL/bin/./CodeXL-bin: error while loading shared libraries: cannot open shared object file: No such file or directory

and this is the listing of the bin directory (which is on the LD_LIBRARY_PATH):

jdart@bunny:~/CodeXL-1.1.1537.0/opt/AMD/CodeXL/bin$ ls











Legal                         Readme.txt

I actually got past this point - I noticed the app was installed into /opt/AMD/CodeXL/bin and that does have the missing libraries.

And now I can start CodeXL but as soon as I try to debug an application I get a message that system libraries and are missing.

I actually have installed in /usr/lib/x86_64-linux-gnu/mesa and have tried symlinking to that. For libOpenCL I have tried installing the AMD OpenCL SDK and linking to that. But this has no effect on the error message.

FYI, I am running a ASUS - KGPE-D16 dual Opteron board with motherboard graphics (no AMD GPU). And my app is a console app (no graphics or GPU usage at all).

4 Replies

I think the problem is that you installed the rpm on an ubuntu system, that does not work well. You'll need to take the tar.gz version and extract it where ever you want and use that version. Based on the ls you displayed you are missing a lot of the needed libraries, unless you did not give the full list. THis should solve your missing library issue.

As for the we assume that the driver is installed correctly. an environment variable LIBGL_DRIVERS_PATH needs to be defined. if it is not defined you can manually define it to a directory bellow the directory that contains those two libraries (if it is /usr/lib64 then set it to /usr/lib64/subdir since it is used for a few other things also and parent dir will be checked also) if this does not work set it to the direct it containing those libraries)


It does not appear to me that the motherboard graphics chip (ASPEED I think) has any OpenCL support.

So I installed a graphics card based on Nvidia GT 610.

That works ok in X but I am still having problems getting CodeXL to work. I am on Ubuntu 12.10. I tried the nvidia-current drivers (version 304.88) and that caused CodeXL to core dump with no message. Installing nvidia-experimental-310 (version 310.14) gives the message from CodeXL "

FATAL: Module fglrx not found.

Error! Fail to load fglrx kernel module! Maybe you can switch to root user to load kernel module directly"

(running as root did not help). I thought fglrx was for ATI graphics cards?


We will try to reproduce the same environment here and try to understand what is causing these issues. I can not commit to when these issues will be address if we will be able to reproduce them, 


Actually, despite the "fatal" message on startup, this latest issue is not a fatal error. CodeXL is running and profiling works (with the 310.14 driver).