Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Adept II

KernelAnalyzer 11.11 on System without AMD GPU

Missing aticalrt.dll

I installed the AMD Kernel Analyzer 11.11 and APP SDK 2.6 on my non-AMD-GPU equipped Laptop (actually in VMWare) to analyze some register utilization issues. While previous version (e.g. Kernal Analyzer 11.7) worked fine in this setup the 11.11 version fails with the following error:

--------------------------- AMDAPPKernelAnalyzer.exe - Systemfehler --------------------------- Das Programm kann nicht gestartet werden, da aticalrt.dll auf dem Computer fehlt. Installieren Sie das Programm erneut, um das Problem zu beheben. --------------------------- OK ---------------------------

It seems to be missing aticalrt.dll, which I assume would normally be provided by the GPU driver. However I also though the Kernel Analyzer brought it's own version of that, to be able to emulate different driver version. Am I doing something wrong, or is this kind of setup no longer supported?

2 Replies
Journeyman III

I had the same problem with this. I installed the regular driver on my non-AMD computer (also a VMware laptop) in hopes it would fix it, but it did not.

Then I got the idea to manually install aticalrt.dll, which ended up working! (well, OpenCL compiling did. I haven't tried IL)

Here's what I did:
In the temp install directory for the AMD driver (default C:\ATI\support\...) in one of the subdirectories there are 3 files you need:

These are compressed versions of the final files. You need something like 7zip to decompress them. With 7zip installed, I right-clicked on each one, selected "7zip->open archive". Inside each of these files you will find the "final" file, so inside the archive of aticalrt.dl_ you will find the file aticalrt.dll.

Extract each of these three dll files to the 32-bit system directory. On 32-bit Windows it's "C:\Windows\System32", 64-bit Windows it's "C:\Windows\SysWOW64".

Once those three DLLs files are copied you _should_ be able to compile and see running speed in the KernelAnalyzer. Hope this helps!

Thanks for your sharing your workaround, omion! It did help, though the bad part about it is, that I now will have to do some work over the holidays. 😉

For anybody trying to reproduce the workaround. For Catalyst 11.12 you'll find the mentioned files in C:\ATI\SUPPORT\11-12_vista64_win7_64_dd_ccc_ocl\Packages\Drivers\Display\W76A_INF\B128376 . Also you'll need a fairly recent version of 7-zip. My version from October 2010 was unable to recognize the dl_ files as archives. Last but not least, I also tried storing the dll files into the KernelAnalzer directory. In that case the KernelAnalyzer would start up just fine, however the OpenCL compiler would fail.