Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

Internal Error : failed to find as

I am trying to install AMD APP SDK 2.9.1 on Linux (RHEL 7), initially just for the CPU device; I plan to test with Radeons once that is working. I followed the instructions for 'non-root installation'. The HelloWorld sample works but none of the other samples work; they all fail with a log similar to;

Selected Platform Vendor : Advanced Micro Devices, Inc.
Device 0 : Intel(R) Xeon(R) CPU E7- 4870  @ 2.40GHz Device ID is 0x238a590

                        BUILD LOG
Internal Error: Failed to find as

Codegen phase failed compilation.


I have checked that LD_LIBRARY_PATH includes AMDAPPSDK-2.9-1/lib/x86_64 and that AMDAPPSDKROOT and OPENCL_VENDOR_PATH are set appropriately. What else can I do to make this SDK work? I have tried JOCL as well but all of the examples fail with the same error, even HelloJOCL. I can't find much on the web about 'Internal Error: failed to find as'; I assume some OpenCL libraries are loading ok, sufficient to get the platform list, but not to compile a kernel.

1 Reply

Re: Internal Error : failed to find as

My apologies for this late reply.

It is very strange that HelloWorld sample is working but not others. Do you have catalyst driver installed? If so, then which version? Please share clinfo output and app sdk related environmental paths. Also, please make sure you had uninstall the previous versions (if any) of APP SDK properly.

BTW, if you follow the "root-mode installation", do you see the same problem?