cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

gsteri1
Journeyman III

Installing the new experimental ATI Stream driver...openSUSE

Driver issues.

Hi,

Apologies if this should have been posted under another topic. I attempted to install the experimental driver in order to run the new version of the SDK. I am running an opensuse 11.1 AMD64 box. The driver installed and I got the warning images (eg No 3D, experimental driver..). Aside from the loss of the 3D acceleration, scrolling did not work. Using the scroll bar on, say firefox, caused both cores of my cpu to approach 100%. Furthermore, none of the examples would run. Has anyone encountered anything similar?

Thank you,

-Greg

Tags (1)
0 Likes
4 Replies
c360
Journeyman III

Installing the new experimental ATI Stream driver...openSUSE

Have you installed the released version Catalyst v 9.10 -r eleased on 10/22/09?

0 Likes
igimenez
Journeyman III

Installing the new experimental ATI Stream driver...openSUSE

Hi Greg


As c360 pointed, I am also 100% sure  ATI catalyst 9.10 is working in openSuSE 11.1, at least for SDK 1.4. The only problem is that you need to correct some silly C bugs in the SDK examples due to the version of GCC that comes with the distrol which is more strict.

I have a couple of 4870X2 crunching here. Maybe are you talking about  SDK 2.0 and latest experimental driver ? What is your GPU card?

 

BR

Ivan

0 Likes
gsteri1
Journeyman III

Installing the new experimental ATI Stream driver...openSUSE

Hi Gents,

Thanks for the replies. I am using the 4850 card. I installed the SKD that was posted on 10/12/2009. This is the 1.4 SDK. The installation instruction claim that the drivers: ati-opencl-beta-driver-v2.0-beta4-lnx.zip (82.3MB) need to be installed. When I installed it, the performance tanked and none of the examples ran... I installed the newest shipping version of the drivers and things are back to normal.

Is the experimental driver required? Things seem to work without it, so I am content to use the production driver...

Thank you,

-Greg

0 Likes
c360
Journeyman III

Installing the new experimental ATI Stream driver...openSUSE

Greg,

Unless your application has been created and compiled to run under OpenCL (aka Stream 2.0 beta) I would use Brook+ 1.4 and CAL 1.4 from March 12, 2009. The files are located on http://developer.amd.com/gpu/ATIStreamSDK/Pages/default.aspx

The apps I currently use are not converted yet to Stream 2.0 SDK which is the driver you installed. I suspect that your app has also not be updated to take advantage of the 2.0 SDK and drivers.

0 Likes