cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

zoomzoom
Adept I

HSA 1.0 API not compatible with 1.0 provisional specs

Jump to solution

The recent release of the 1.0 HSA specifications has several differences compared with the previous 1.0 provisional specs.

Here are just some of the changes that I have noticed:

  • hsa_dispatch_packet_t does not exist anymore. Seems to have been replaced by hsa_kernel_dispatch_packet_t
  • hsa_barrier_packet_t also does not exist in 1.0 specs
  • The extensions to the core runtime API have changed. hsa_ext_program_handle_t, hsa_ext_add_module are not present in 1.0 anymore

Any idea when AMD will have an update ready for its HSA RT?

Thanks.

Tags (1)
0 Likes
1 Solution

Accepted Solutions
jtrudeau
Staff
Staff

Re: HSA 1.0 API not compatible with 1.0 provisional specs

Jump to solution

I can't make definitive statements about future release dates. We are very aware of the differences, and are working on an update to the runtime. We will release that ASAP. Obviously, there will be some latency between the spec going final, and the release of actual code that conforms to the spec.

I wish I could tell you "two weeks" or "four weeks" but at least I can tell you this: ASAP. We are eager to get this out the door.

View solution in original post

0 Likes
3 Replies
jtrudeau
Staff
Staff

Re: HSA 1.0 API not compatible with 1.0 provisional specs

Jump to solution

I can't make definitive statements about future release dates. We are very aware of the differences, and are working on an update to the runtime. We will release that ASAP. Obviously, there will be some latency between the spec going final, and the release of actual code that conforms to the spec.

I wish I could tell you "two weeks" or "four weeks" but at least I can tell you this: ASAP. We are eager to get this out the door.

View solution in original post

0 Likes
zoomzoom
Adept I

Re: HSA 1.0 API not compatible with 1.0 provisional specs

Jump to solution

Thank you for the quick reply.

We are also looking forward to having an implementation fully compatible with the 1.0 specifications. So keep up the good work!

0 Likes
zoomzoom
Adept I

Re: HSA 1.0 API not compatible with 1.0 provisional specs

Jump to solution

It looks like the Runtime was updated a few days ago and is compatible with the official HSA 1.0 API: HSAFoundation/HSA-Runtime-AMD · GitHub

A new version of the HSA driver was also released: HSAFoundation/HSA-Drivers-Linux-AMD · GitHub

0 Likes