Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Adept II

Hardware diags, test, & burn-in tools?

I recently installed a HD 6850.  In the reviews of this particular board vendor's implementation, I've seen some recent complaints about defective units.  I'd like an easy way to stress test it, while it's still easy to return/exchange (the place where I bought it has a nice 30-day exchange policy).

How do people test their hardware?  I'm running Linux (Ubuntu x86-64, if that matters).  I'd rather spend my time debugging my code than my hardware. 

I have so far run the OpenCL version of this (when you unpack it, you'll see an OpenCL version).  I'm glad to have a way to check for bad memory, though I don't know how stressful it really is:

I've run LuxMark, but I didn't see any way to loop it.  Though I had many successful runs, it completely froze my machine (couldn't even ping it) twice, which has never previously happened on this machine.  It also seems to leak resources.  I could only run the complex scene if it was the first one I tried.

And I've tried LightsMark, which is an OpenGL 2.0 lighting benchmark that is probably more memory-bound than shader-intensive.

I'm still looking for an OpenCL or OpenGL benchmark or burn-in program for linux that is definitely shader-bound.  I looked into bitcoin mining tools, but it seemed like a lot of trouble to setup.

3 Replies

just select interactive mode from Mode menu and LuxMark will run endlesly.



I wish I had some insight into the reason it froze my PC, those two times.  Are there known bugs in the APP SDK which could have this effect?  The release notes indicate that a deadlocked kernel could hang the X-server & the program running the kernel, but it was fairly specific about these processes and didn't say anything about the entire OS seizing up.

BTW, the problem always happened when changing scenes.  It doesn't seem to occur in interactive mode.


There are a couple of memory leaks in LuxMark 2.0 when switching scene. They have been fixed in the latest sources but you may have some problem if you are using the precompiled 2.0 binary and you are short in RAM.