cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

wh1sp3r
Journeyman III

GPUPerf Studio - Windows 8.1

Hello,

I tested GPUPeft Studio on Windows 8.1 and unfortunately, it's not working.

After i connect to the server ( this seems to be working ), i choose DX11 API, GPUPerf Studio freeze.

I tested compability mode, run as administrator, turn firewall off, different port.

I hope, it will be solved soon, this software is really helpful 😉

Tags (2)
0 Likes
16 Replies
wh1sp3r
Journeyman III

Re: GPUPerf Studio - Windows 8.1

I did more tests and i realized, other graphic programs can be debugged.

So, i am confused now, why my application cannot be debugged. Code is compiled with v110 toolset ( VS 2012 ). DirectX 11 is created with debug flag.

GPUPerf server shows last item "

19:06:03.257790: Message: 4476 Server    :   5: 127.0.0.1  - /5016/DX11/ShowStack

Also, i can't get that data from internet browers too, so perhaps that's why GPUpert studio can't connect and it freeze.

I also commented out all rendering from my app, and i left only creating graphics and present command. Still can't connect.

I have no idea, where is a problem

0 Likes
darkradeon
Adept III

Re: GPUPerf Studio - Windows 8.1

I confirm that GPUPerfStudio 2 doesn't work on Windows 8.1 Pro RTM (x64)

0 Likes
darkradeon
Adept III

Re: GPUPerf Studio - Windows 8.1

same issue with the last version (2.14.1665.0)

it seems that the tool must be updated to work with the last directx runtimes...

0 Likes
wh1sp3r
Journeyman III

Re: GPUPerf Studio - Windows 8.1

Yep. Same here.

0 Likes
Lonesled
Staff
Staff

Re: GPUPerf Studio - Windows 8.1

Hi, currently GPS2 does not work with applications built against the Win8 SDK. VS2012 (and the Win8 SDK) uses a new runtime that undermines how GPS2 gets inside your application.I would recommend using the VS2012 graphics debugging tools for now until we get a fix.

wh1sp3r
Journeyman III

Re: GPUPerf Studio - Windows 8.1

Hello Lonesled,

well, it was some time ago we talked about this problem. I would like to know, when this is going to be fixed ? Any information about that ? Beta versions ?

Thank you very much for your answer.

0 Likes
Lonesled
Staff
Staff

Re: GPUPerf Studio - Windows 8.1


Hi, could you try again using the following settings. Before you connect open the client and go to Windows/Settings. In the General tab there is a radio button selection for "Time Spoofing on pause". If your current setting is on Freeze then set it to None and try to connect. Are you using a frame-limiter of some kind? i.e. waiting for time to progress to some value before rendering the next frame? If you are, then the None option should fix this.

Also, your application must be in a continual rendering loop calling Present at the end of each frame. if you app is back-grounded, it must continue to render (some apps stop rendering if they do not have focus).

0 Likes
wh1sp3r
Journeyman III

Re: GPUPerf Studio - Windows 8.1

Hello,

thank you for reply. I tested your suggestions, unfortunately with same results.

Application is in continous loop and presets graphics every frame. I am not using anykind of frame limited, except vertical synchronization.

Log did not say anything helpful, last log item is

PID: 4060, TID: 6648           : Message: 4060 GPUPerfServer :  26: 127.0.0.1  - /3912/DX11/ShowStack

Also, I tried something different. When GPUPerf server running, I am able to write URL into my browser like

http://127.0.0.1:50000/Process.xml

and I am able to get info about process in XML format.

when I try http://127.0.0.1:50000/3912/DX11/ShowStack, I am not able to get anything. Only one error in log "Error SocketReadHeader - 0" but it's possible it's my fault as i entered not valid URL , who knows, only developers

0 Likes
darkradeon
Adept III

Re: GPUPerf Studio - Windows 8.1

I have the same issue, running Windows 8.1.

Other 3rd party profilers (MS VS 2013 graphics debugger, intel gpa) work fine, but of course they cannot give me GCN shader assembly like GPUPerfstudio 😕

0 Likes