Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

GPU not found. Falling back to CPU device

Hello -

I'm having an issue getting OpenCL to work with Radeon HD 6970. When I try to run sample programs from SDK v2.4 (such as 'Histogram') I get the message:

"GPU not found. Falling back to CPU device".

I assume that this indicates a problem with the driver? When I run 'fglrxinfo'  it only returns 'Segmentation fault (core dumped)'. I'm working on Red Hat Enterprise Linux release 6.1 with Catalyst 11.4 installed. We initially had the latest driver installed and had the same problem. We then installed Catalyst 11.4 since it is listed as the tested driver on the SDK v2.4 download page, but we still have the same problem.

I don't have root access and therefore didn't install the driver myself - everything goes through a systems administrator.

Any suggestions would be appreciated!


11 Replies
Journeyman III

I have the same problem with SDK v2.4 on ATI Mobility Radeon 5650. I also tried to install different versions of drivers from 11.4 to the latest but this doesn't work..


Solved! - The issue was related to logging in remotely (ssh). 

I hadn't had access to the actual computer until today - the sample programs were able to find the GPU when run directly on the machine. 

To make the GPU visible when logging in remotely, I had to export DISPLAY=:0. This solved all of my problems.

I found this solution here:


I now tried to run these samples directly from the machine, but the problem remains...

I have a switchable graphics (Intel HD Graphics + ATI Mobility Radeon HD 5650) and I've read somewhere that new version of drivers doesn't support such configuration. 

If any of you have any suggestions please reply)


You should create a problem report on AMD's support page.


I have a ATI Radeon HD 4600 Graphics card . But when i am running the OpenCL programs e.g. matrix multiplication , it says gpu not found falling back to cpu. I obviously have a GPU , but how to use it ?

Please anyone help......


I have got the same problem (Windows 7 - 64 bit, ATI Radeon HD 4530 card). I have installed the latest AMD-APP-SDK and updated the graphics driver. I looked at the AMD samples and executed "BinarySearch.exe" - resulting in the "GPU not found ..." message.

Did anyone find a way to use the GPU? How can I narrow down the problem?


I have a 4670, and for that card, OpenCL got deprecated in the latest driver versions.


So far I was told that graphic cards - which run on a Laptops usually have very limited capabilities. That means there is only a small chance that the GPU computing capability will work (e.g. when using Matlab).

Another issue I encountered is Window's Remote Desktop Connection, which causes the same message. I did overcome this by using TeamViewer - TightVNC should also work.

Adept III

hi kirsten,

run the following command and see which devices come up

sudo clinfo

it could be that the radeon board is in an ultra low power savings mode or a deep sleep mode in which case its not getting recognized (just a hunch)

can those who are having this issue and know that their driver supports the card try launching some 3D application to wake the card up and while the 3d app is running try the open cl app or even the clinfo command

apps you can try are ungine benchmarks in windowed mode or furmark


AFAIK only 7xxx radeons have deep sleep mode. but i know that for 4xxx support for OpenCL was removed after Catalyst 11.2- 11.4.

Journeyman III

On the 4670, driver version 12.4 still has OpenCL support.