cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Quartz
Adept II

glPushDebugGroup() broken in 13.12 WHQL drivers

Jump to solution

6.14.10.12618 (13.12 WHQL) drivers, doing glPushDebugGroup() causes GL_INVALID_OPERATION.

Using a 6870 card for testing.

From: http://www.opengl.org/registry/specs/KHR/debug.txt

Trying:


// Setup of the default active debug group: Filter everything in


  glDebugMessageControl(GL_DONT_CARE, GL_DONT_CARE, GL_DONT_CARE, 0, NULL, GL_TRUE);



  // Generate a debug marker debug output message


  glDebugMessageInsert(


  GL_DEBUG_SOURCE_APPLICATION,


  GL_DEBUG_TYPE_MARKER, 100,


  GL_DEBUG_SEVERITY_NOTIFICATION,


  -1, "Message 1");



  // Push debug group 1


  glPushDebugGroup(


  GL_DEBUG_SOURCE_APPLICATION,


  1,


  -1, "Message 2");






returns GL_INVALID_OPERATION at the glPushDebugGroup() call.

There are no other openGL drivers to try that are newer than 6.14.10.12618 for vista 64bit.  AMD don't seem to offer BETA drivers for 14.1 or 14.2 for Vista 64bit.

looking at http://www.opengl.org/sdk/docs/man/d...DebugGroup.xml

for errors, it lists:

Errors

GL_INVALID_ENUM is generated if the value of source is neither GL_DEBUG_SOURCE_APPLICATION nor GL_DEBUG_SOURCE_THIRD_PARTY.
GL_INVALID_VALUE is generated if length is negative and the number of characters in message, excluding the null-terminator, is not less than the value of GL_MAX_DEBUG_MESSAGE_LENGTH.

So, GL_INVALID_OPERATION isn't even listed as a possible error, so, this looks like a driver bug.

Yeah, I am sure it is the glPushDebugGroup() call that causes that error, I added glGetError() calls between and before all calls.

Tags (2)
0 Likes
1 Solution

Accepted Solutions
gsellers
Staff
Staff

Re: glPushDebugGroup() broken in 13.12 WHQL drivers

Jump to solution

Hi,

We've investigated the issue. We're incorrectly setting an error when this function is called outside of a debug context. If you create a debug context, it should work. We have fixed the problem in the driver and will include the fix in a future release.

Thanks,

Graham

View solution in original post

0 Likes
4 Replies
Quartz
Adept II

Re: glPushDebugGroup() broken in 13.12 WHQL drivers

Jump to solution

This is still broken in the latest 14.3 v1.0 drivers.

OpenGL Version: 4.3.12798

0 Likes
gsellers
Staff
Staff

Re: glPushDebugGroup() broken in 13.12 WHQL drivers

Jump to solution

Hi,

We've investigated the issue. We're incorrectly setting an error when this function is called outside of a debug context. If you create a debug context, it should work. We have fixed the problem in the driver and will include the fix in a future release.

Thanks,

Graham

View solution in original post

0 Likes
Quartz
Adept II

Re: glPushDebugGroup() broken in 13.12 WHQL drivers

Jump to solution

Thanks for the update, it is appreciated!

0 Likes
Quartz
Adept II

Re: glPushDebugGroup() broken in 13.12 WHQL drivers

Jump to solution

Ack, Cat 14.4 WHQL are still broken with this issue...

OpenGL Version 6.14.10.12874

Mind saying which version of the openGL drivers will fix this issue ?

0 Likes