Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

fglrx fails to load on HD6620G/HD6700M

I'm trying to use AMD's opencl on my AMD A8 laptop with switchable graphics.

lspci | grep VGA
00:01.0 VGA compatible controller: ATI Technologies Inc Device 9641
01:00.0 VGA compatible controller: ATI Technologies Inc NI Whistler [AMD Radeon HD 6600M Series]

I installs catalyst 12.1 on an ubuntu 11.10 system but xorg falls back to VESA due to a bios read error. Is there some way to blacklist the discrete HD6700M adapter and use only the APU?

Than you

[    74.921] (==) fglrx(1): ATI 2D Acceleration Architecture enabled

[    74.921] (--) fglrx(1): Chipset: "AMD Radeon 6600M and 6700M Series"

(Chipset = 0x6741)

[    74.921] (--) fglrx(1): (PciSubVendor = 0x103c, PciSubDevice = 0x358d)

[    74.921] (==) fglrx(1): board vendor info: third party graphics adapter -

NOT original ATI

[    74.921] (--) fglrx(1): Linear framebuffer (phys) at 0xe0000000

[    74.921] (--) fglrx(1): MMIO registers at 0xf0300000

[    74.921] (--) fglrx(1): I/O port at 0x00003000

[    74.921] (==) fglrx(1): ROM-BIOS at 0x000c0000

[    74.923] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not


[    74.923] (EE) fglrx(0): Invalid video BIOS signature!

[    74.923] (EE) fglrx(1): GetBIOSParameter failed

[    74.923] (EE) fglrx(1): PreInitAdapter failed

[    74.923] (EE) fglrx(1): PreInit failed

[    74.923] (II) fglrx(1): === [xdl_xs110_atiddxPreInit] === end

9 Replies

I'm having similar problems with Catalyst 11.11, 11.12, and 12.1 with my system:

I later found in the release notes for Windows 7 Catalyst drivers that switchable graphics are not supported, but I can't find any statement for Linux Catalyst drivers--release notes are several months old.

Also, it seems AMD's policy for such notebooks as mine is to get the driver from the system builder directly; however their drivers, specifically those provided by HP, are well outdated and also have issues of their own (I think driver version 8.900.7.100).  I'd like AMD to support these kinds of systems for both Windows and Linux as system builders are not reliable current-driver providers.  Without good driver support directly from AMD how are developers going to build and test these systems?

If someone from AMD could (officially or unofficially) comment on this issue and provide a timeline when we could expect working support I'd appreciate it.



I have a HP DV6-6188ca.  Using an unlocked bios from bios-mods I could access to BIOS's graphic card settings that allows to select various PowerXpress modes, hybrid crossfire modes.  I tried to deactivate the discrete GPU without any luck. I'm still stuck in VESA mode.



Please try this driver to see if it fixes your issue.

Because of support issues, only the official release of the driver from your vendor is supported.


Hi Micah,

Thank you for your reply.  Could you tell me why we should try the 12.1a preview driver when we already tried the 12.1 official release driver?

The official release driver from HP is woefully old for Windows 7, and doesn't exist for Linux, so it only makes sense to seek support directly from AMD.  I also bought my system entirely because of the AMD components listed above, not because it was an HP.  If AMD markets products directly to consumers then AMD should directly support those products, just like AMD does with desktop graphics cards.

By the way, there seem to be different Windows 7 drivers on the AMD website for desktops and laptops (denoted with _mobility_), what about for the chipset driver?  I can't find a _mobility_ version, so does the one chipset driver version work for both?



Laptop vendors control the process for how drivers are updated and in some cases restrict the capabilities of those devices. This is not something that AMD has direct control over, so it is an issue you will have to take up with your laptop vendor. Our preview releases might not have the same restrictions as the official releases, so these features might not be disabled for your specific device.


In the AMD Catalyst™ Display Driver 12.1 Release Notes, how come under "AMD Mobility Radeon™ Product Families," it says it supports the 6990M, 6800M, and 6300M series, but not the series in between?  Also, both the 6300M and 6300 series are listed, which I'm guessing is some kind of typo?  Just another slight observance, but it looks like some models are missing their "M" after their numbers, and there is an inconsistent use of "TM" in the list.

Anyways, if AMD supports some notebook graphics as noted above, AMD's consumers would really like it if they supported all of them, and switchable graphics .  Happy consumers leads to repeat consumers and good publicity via word of mouth.


Note that our laptops find into the "AMD PowerXpress™ enabled notebooks using AMD chipsets" category, so they are supported.

FGLRX does support our GPU's model numbers and properly reports them as "Chipset: "AMD Radeon 6600M and 6700M Series"

We simply hit a bug, period. I configured my xorg.conf not to use the discrete graphics chipset, it should at least allow me to do that.


This issue seems to have been fixed in the Catalyst 12.2 driver.  I can boot my system successfully and even switch between the integrated and discrete gpu.  Things are looking much better. 


I have this issue with AMD Catalyst™ 12.6 Proprietary Linux x86 Display Driver on a HP DV6-6b92eg running a backported 3.2 kernel on Debian Squeeze. VGA Device is 9641.

Pleas tell me how to work around this or even solve the problem altogether!