cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

krishraov
Journeyman III

ERROR: Unable to get device_id

Can't get OpenCL to work on Win 7 and VS2010

Hi,

I am using Visual Studio 2010 on a Dell Precision T3500 workstation. It has a Intel Xeon quad-core CPU and an ATI FirePro 4800 graphics card. I installed the latest AMD APP SDK and followed all the instructions given in the "Introduction to OpenCL Programming" guide and tried to get the "Helloworld" program running -- but it is not. It gives the error -- "unable to get device_id".

 

When I run the "clinfo" program, I get the following output:

----------------------------------------------------------------------------------------------

C:\Program Files (x86)\AMD APP\bin\x86_64>clinfo
Number of platforms:                             1
  Platform Profile:                              FULL_PROFILE
  Platform Version:                              OpenCL 1.1 AMD-APP-SDK-v2.4 (59
5.10)
  Platform Name:                                 AMD Accelerated Parallel Proces
sing
  Platform Vendor:                               Advanced Micro Devices, Inc.
  Platform Extensions:                           cl_khr_icd cl_amd_event_callbac
k cl_amd_offline_devices cl_khr_d3d10_sharing


  Platform Name:                                 AMD Accelerated Parallel Proces
sing
Number of devices:                               1
  Device Type:                                   CL_DEVICE_TYPE_CPU
  Device ID:                                     4098
  Max compute units:                             4
  Max work items dimensions:                     3
    Max work items[0]:                           1024
    Max work items[1]:                           1024
    Max work items[2]:                           1024
  Max work group size:                           1024
  Preferred vector width char:                   16
  Preferred vector width short:                  8
  Preferred vector width int:                    4
  Preferred vector width long:                   2
  Preferred vector width float:                  4
  Preferred vector width double:                 0
  Native vector width char:                      16
  Native vector width short:                     8
  Native vector width int:                       4
  Native vector width long:                      2
  Native vector width float:                     4
  Native vector width double:                    0
  Max clock frequency:                           3066Mhz
  Address bits:                                  64
  Max memory allocation:                         3220584448
  Image support:                                 Yes
  Max number of images read arguments:           128
  Max number of images write arguments:          8
  Max image 2D width:                            8192
  Max image 2D height:                           8192
  Max image 3D width:                            2048
  Max image 3D height:                           2048
  Max image 3D depth:                            2048
  Max samplers within kernel:                    16
  Max size of kernel argument:                   4096
  Alignment (bits) of base address:              1024
  Minimum alignment (bytes) for any datatype:    128
  Single precision floating point capability
    Denorms:                                     Yes
    Quiet NaNs:                                  Yes
    Round to nearest even:                       Yes
    Round to zero:                               Yes
    Round to +ve and infinity:                   Yes
    IEEE754-2008 fused multiply-add:             No
  Cache type:                                    Read/Write
  Cache line size:                               64
  Cache size:                                    32768
  Global memory size:                            12882337792
  Constant buffer size:                          65536
  Max number of constant args:                   8
  Local memory type:                             Global
  Local memory size:                             32768
  Kernel Preferred work group size multiple:     1
  Error correction support:                      0
  Unified memory for Host and Device:            1
  Profiling timer resolution:                    333
  Device endianess:                              Little
  Available:                                     Yes
  Compiler available:                            Yes
  Execution capabilities:
    Execute OpenCL kernels:                      Yes
    Execute native function:                     Yes
  Queue properties:
    Out-of-Order:                                No
    Profiling :                                  Yes
  Platform ID:                                   0000000002EDD118
  Name:                                          Intel(R) Xeon(R) CPU
W3550  @ 3.07GHz
  Vendor:                                        GenuineIntel
  Driver version:                                2.0
  Profile:                                       FULL_PROFILE
  Version:                                       OpenCL 1.1 AMD-APP-SDK-v2.4 (59
5.10)
  Extensions:                                    cl_khr_fp64 cl_amd_fp64 cl_khr_
global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int3
2_base_atomics cl_khr_local_int32_extended_atomics cl_khr_int64_base_atomics cl_
khr_int64_extended_atomics cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ex
t_device_fission cl_amd_device_attribute_query cl_amd_vec3 cl_amd_media_ops cl_a
md_popcnt cl_amd_printf cl_khr_d3d10_sharing

 

Can someone help me out here? I am stuck .... Thank you !

 

0 Likes
4 Replies
himanshu_gautam
Grandmaster

ERROR: Unable to get device_id

What driver have you installed for the GPU?

0 Likes
krishraov
Journeyman III

ERROR: Unable to get device_id

Hi,

The driver details are : 8.701.0.0

0 Likes
krishraov
Journeyman III

ERROR: Unable to get device_id

Hi,

The driver details are : 8.701.0.0

0 Likes
krishraov
Journeyman III

ERROR: Unable to get device_id

UPDATE:

  1. I checked the requirements for SDK 2.4 and it needs 8.841 drivers. But those do not support FirePro V4800. (please correct me if I am wrong here).
  2. I uninstalled V2.4 of the SDK and installed V2.01 of the SDK. Now my GPU is detected and all the samples run fine. It does not give an error message "Rolling back to the GPU".
  3. I might have missed a lot of support by using V2.01. If so, please can you tell me what I can do to get V2.4 working?

Thank you !

0 Likes