cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

mhtuc
Journeyman III

DOPP PresentTextureToVideo not working

Jump to solution

Hi,

I'm trying to get the DOPPEfectOpenGL from the DOPP SDK 1.0 working. Using the capture window works nicely, but I never get the effect applied to the full output. I've added some debug outputs to the sample code. The display texture is ID 1, the present texture is ID 2, both have the correct resolution matching my desktop. wglPresentTextureToVideoAMD() is called every frame, wglEnablePostProcessAMD(true) is called once, and there are never any GL errors.

System setup is:

FirePro W9000 wirh latest drivers: Catalyst Pro, 14.301.1010 from Nov 18.

Win7 64Bit,

DOPP is enabled via DOPPenable.exe as admin

I've checked with a 2x2 Eyfinity Group as well as a single display setup.

Is there something I'm missing? Or something I could try?

0 Likes
1 Solution

Accepted Solutions
chm
Staff
Staff

Re: DOPP PresentTextureToVideo not working

Jump to solution

Hi,

do you have DWM/Aero turned on? If not please turn it on and check if the desktop texture gets replaced.

Chris

View solution in original post

0 Likes
2 Replies
chm
Staff
Staff

Re: DOPP PresentTextureToVideo not working

Jump to solution

Hi,

do you have DWM/Aero turned on? If not please turn it on and check if the desktop texture gets replaced.

Chris

View solution in original post

0 Likes
mhtuc
Journeyman III

Re: DOPP PresentTextureToVideo not working

Jump to solution

Hi,



do you have DWM/Aero turned on? If not please turn it on and check if the desktop texture gets replaced.



That was it. Thank you!

I thought that I had even tested with both areo on and off before, but whatever.

0 Likes