cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

titanius
Adept II

Does the SDK-1.3 beta work with Catalyst 9.2?

problems with SDK and catalyst

This might be a totally stupid question but everything worked swimmingly when i use the Radeon 4830 with Catalyst 8.12 and SDK 1.3. On Debian x86-64.

But upgrading to Catalyst 9.2 I encounter problems with CAL and Brook:

"Supported CAL Runtime Version: 1.3.145
Found CAL Runtime Version: 1.3.158
There was an error opening the device 0.
Error string is Parameter passed in is invalid" and nothing happens

Not even FindNumDevices (that comes with CAL samples) work.

But the info command which comes with acmlg1.0 works showing it detected a GPU etc etc, but none of the acml stuff work.

 

Any help regarding this will be most welcome.

Is this all due to the fact that the runtime now given by new catalyst for CAL is not supported by the SDK "shown in the error message above"?

Also, Has anyone got the acml1.0 working with the newer drivers Catalyst 9.2 on (linux x86-64)?

 

Thanks.

 

0 Likes
6 Replies
rahulgarg
Adept II

Does the SDK-1.3 beta work with Catalyst 9.2?

Recompile the sample applications in CAL. Those binaries were probably compiled against catalyst 8.12 (which had libamdcalrt.so etc). In catalyst 9.2, these got renamed to libaticalrt.so. So to make the sample applications run, I modified the makefile for samples and did a make.

About ACML : sorry I dont know. I could not get it to work since it requires gfortran 4.1 while I had gfortran 4.3 and the two are not compatible.

 

0 Likes
titanius
Adept II

Does the SDK-1.3 beta work with Catalyst 9.2?

Thanks a lot rahulgarg! It seems to fix things with CAL.

It seems that the latest catalyst has the libamdcal* all replaced with libatical*

 

changing the makefile.common (in amdcal) by replacing LIBS+= $(LINKSWITCH) amdcalrt and amdcalcl with aticalcrt and aticalcl fixes things for CAL.

 

The other option is to remove(moving to some other name) libamdcal* and link libatical* as libamdcal* which fixes things for both CAL and brook.

 

0 Likes
titanius
Adept II

Does the SDK-1.3 beta work with Catalyst 9.2?

I think i got ACML working without installing gfortran

 

Running ACML (C-interface) without installing gfortran4.1:

The latest version of debian and ubuntu and don't have access to gfortran-4.1 and to use atleast the usual C interface one will need to get the latest library interface for gfortran

For example for debian, one will need to download the deb package from

http://packages.debian.org/etch/libgfortran1

and extract the library via dpkg --extract and copy all lib* to /usr/lib and then ACML-GPU works for the C-interface.

 

 

 

0 Likes
rahulgarg
Adept II

Does the SDK-1.3 beta work with Catalyst 9.2?

Thanks .. extracting libgfortran1 from deb also worked for me !!

 

0 Likes
twinclouds
Journeyman III

Does the SDK-1.3 beta work with Catalyst 9.2?

I try to run GPU for computation without much specific program other than normal c/c++.  Can I use my normal c program and linking it with the ACMLgpu library?  Thanks.

0 Likes
titanius
Adept II

Does the SDK-1.3 beta work with Catalyst 9.2?

Yup, ACML-gpu and C programs work well. For my case i Have been using the Matlab's C/C++ interface to run GEMM routines.

0 Likes