cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

tomreyn
Journeyman III

Disable OpenCL profiling / debugging (libOpenCL.so.1 missing)

Hi,

I'm on Ubuntu 13.10 x86_64 and am stuck on old Radeon X-series hardware which is no longer supported by fglrx, so I'm using the Mesa / Gallium driver set (r300(g)). This hardware does not support OpenCL (nor do the Mesa drivers Ubuntu currently provides).

So I'd like to use CodeXL without OpenCL debugging and profiling. Re: libOpenCL.so.1 are missing suggests this is possible, but does not explain how. Since I do not have libOpenCL.so.1, whenever I try to start in DebugMode I run into the

The following system libraries are missing: libOpenCL.so.1

message - which is factually correct, but I'd like to work around this issue, if possible, and make use of the remaining functionality CodeXL provides only. Using Gremedy's gDEBugger 5.8.1 (which CodeXL seems to be based on) I can use all three analysis modes fine (by setting the project profile to OpenGL only (no OpenCL)).

Is it still possible to disable OpenCL support in CodeXL, and if so, how?

Thanks in advance.

0 Likes
2 Replies
urishomroni
Staff
Staff

Re: Disable OpenCL profiling / debugging (libOpenCL.so.1 missing)

Hi tomeryn,

Since AMD (and most other vendor's) drivers all install the OpenCL ICD, we currently require it to exist on the system when debugging.

1. We will consider adding such an option in future versions of CodeXL.

2. As a workaround, try creating an empty file named /usr/lib/libOpenCL.so.1 (since your machine does not have OpenCL installed, I assume the application you're running is not using OpenCL 😃 ), and seeing if that allows you to debug.

Hope this helps,

tomreyn
Journeyman III

Re: Disable OpenCL profiling / debugging (libOpenCL.so.1 missing)

Hello Uri,

thanks for the fast response. You are right in that the application I'm trying to debug (the MegaGlest open source game) does not depend on / support OpenCL.

Creating an empty and executable file /usr/lib/libOpenCL.so.1 did help indeed, thanks. I had done so before, but in different directories, without effect. With this new file, I now get this message:

You do not have a supported AMD GPU. OpenCL kernel debugging will be disabled.

... which is fine and correct.

Note also that I had previously installed Ubuntu – Details of package ocl-icd-libopencl1 in saucy and pointed the LIBGL_DRIVERS_PATH and LD_LIBRARY_PATH environment variables towards the directory the libOpenCL.so.1 this package provides would reside in, but this would not result in any change of behaviour on CodeXL's part.

Anyways, for now it works as well as it could for me, thanks!

Tom

0 Likes