cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

jwollen
Journeyman III

DescriptorSet copies silently failing

Jump to solution

When calling vkUpdateDescriptorSets with any VkCopyDescriptorSet, no copies seem to be performed. Binding the destination sets produces no errors, but no resources get bound.

This can be easily reproduced in the cube demo of the VulkanSDK (version 1.0.13). The modified source can be found in this Gist​.

This was tested on

- Sapphire R9 270x, Windows 10, driver package 16.20 and

- an APU, Windows 7, driver package 16.15, as well as Linux

It behaves as exprected on various GPUs of other vendors.

Tags (2)
0 Likes
1 Solution

Accepted Solutions
dwitczak
Staff
Staff

Re: DescriptorSet copies silently failing

Jump to solution

I can confirm this is a driver-side issue. Thank you very much for the feed-back, we are going to investigate this problem shortly.

View solution in original post

0 Likes
3 Replies
dwitczak
Staff
Staff

Re: DescriptorSet copies silently failing

Jump to solution

Thank you for your report. I'm going to have a look at this issue later today. Will get back to you as soon as I have more information to share.

0 Likes
dwitczak
Staff
Staff

Re: DescriptorSet copies silently failing

Jump to solution

I can confirm this is a driver-side issue. Thank you very much for the feed-back, we are going to investigate this problem shortly.

0 Likes
dwitczak
Staff
Staff

Re: DescriptorSet copies silently failing

Jump to solution

The issue has been resolved. The problem should no longer reproduce, starting with the next but one driver release.

0 Likes