Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

could not debug kernel...


     I met an error that is "Could not debug kernel. This kernel uses unsupported features. Please check the release notes for more details" when I was trying to debug my kernel by gDEbugger. Then I found the similar information about it which says install CodeXL to replace gDEbugger, so I followed the method and tried again. Another error was thrown that is "Could not debug the kernel.,This kernel uses unsupported features.Kernel might be using printf command". How can I debug my kernel with CodeXL or gDEbugger?


          OS : Window7 32Bits

          Develop tools: Visual studio 2010 Ultimate

          Device: AMD Radeon HD 7850

          Catalyst version: 13.9

          OpenCL 1.2

          CodeXL version 1.2

          gDEBugger 6.2

     Btw, I can debug the teapot sample code without any exceptions, any ideas?

Thanks for the help!

3 Replies
Journeyman III

Can anyone tell me how to solve this problem?


I have the same problem with gDebugger 6.1.76 integrated in Visual Studio 2010: "the kernel uses unsupported features".

          OS : Window7 64Bits

          Develop tools: Visual Studio 2010

          GPU Device: AMD Radeon HD 5650

          Catalyst version: 13.9 (tried to install older drivers too: 13.5, 13.4, 13.2beta, 13.1, 12.4. The last one referenced in another topic, but too old to support gDebugger on VS2010 actually, I guess)

          OpenCL 1.2

          AMD APP SDK 2.8 (tried to downgrade to 2.6)

          CodeXL version 1.2 (with sdk 2.6 should be 1.1)

          gDEBugger 6.2 (standalone outside VS2010, 6.1.76 integrated in VS2010

Getting mad.


Anyway, I remembered to have read something about printf here. Try to check if it works and please reply me you fix it.

I wanna solve this issue too. I'm gonna continue to face gDebugger on VS2010, since it can be a very useful too, IF IT WORKS!!!!!!!