Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

CodeXL segmentation fault on start - Ubuntu 14.04 - Radeon 390

I'm having what I believe is the same issue as CodeXL 1.8 Crashing - Debian. CodeXL crashes with a segmentation fault on Ubuntu 14.04 using a Radeon 390.

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
[New Thread 0x7fffdf164700 (LWP 1405)]
[New Thread 0x7fffde963700 (LWP 1406)] 

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffde963700 (LWP 1406)]

0x00007fffece0ae2c in __GI___libc_free (mem=0x7fffffffe6f2) at malloc.c:2945 2945    
malloc.c: No such file or directory.

(gdb) bt
#0  0x00007fffece0ae2c in __GI___libc_free (mem=0x7fffffffe6f2) at malloc.c:2945
#1  0x00007ffff7e92acd in ?? () from /usr/lib64/
#2  0x00007ffff7e92866 in ?? () from /usr/lib64/
#3  0x00007ffff7e92590 in amdPcsGetStr () from /usr/lib64/
#4  0x00007fffddfe05ba in ADL2_Graphics_Versions_Get () from /usr/lib/
#5  0x00007ffff772602c in oaGetDriverVersion (driverError=@0x7fffde962ac0: -1) at /data/jenkins/workspace/CodeXL-1.8-Linux/release/CodeXL/1.8/CommonProjects/AMDTOSAPIWrappers/src/linux/oaDriver.cpp:130
#6  0x00007ffff6a3e155 in afSystemInformationCommand::getSystemInformationDataAsString (this=this@entry=0x7fffde962ba0, systemInformationStr=...)     at /data/jenkins/workspace/CodeXL-1.8-Linux/release/CodeXL/1.8/CommonProjects/AMDTApplicationFramework/commands/afSystemInformationCommand.cpp:3065
#7  0x00007ffff6a3e3c0 in afSystemInformationCommandThread::entryPoint (this=0x693fb0) at /data/jenkins/workspace/CodeXL-1.8-Linux/release/CodeXL/1.8/CommonProjects/AMDTApplicationFramework/commands/afSystemInformationCommand.cpp:51
#8  0x00007ffff7991887 in osThread::threadEntryPoint (pParam=0x693fb0) at /data/jenkins/workspace/CodeXL-1.8-Linux/release/CodeXL/1.8/CommonProjects/AMDTOSWrappers/src/linux/osThread.cpp:76
#9  0x00007fffec766182 in start_thread (arg=0x7fffde963700) at pthread_create.c:312 #10 0x00007fffece8247d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

I can't reply in the referenced thread but would like to provide more information (see attached system info dumps).

I'm also seeing a segmentation fault running the teapot example.

#0  0x0000000000000000 in ?? ()

#1  0x00007fffedb1f7af in ?? () from /usr/lib64/

#2  0x00007fffeda1eec4 in ?? () from /usr/lib64/

#3  0x00007fffeda1efd9 in ?? () from /usr/lib64/

#4  0x00007fffeda2ad0b in ?? () from /usr/lib64/

#5  0x00007fffed9ef19e in clCreateContext () from /usr/lib64/

#6  0x00000000004136fa in AMDTTeapotOCLSmokeSystem::initOpenCLResources (this=0x6c9590) at Examples/AMDTTeaPot/AMDTTeaPotLib/src/AMDTTeapotOCLSmokeSystem.cpp:1167

#7  0x0000000000414607 in AMDTTeapotOCLSmokeSystem::draw (this=0x6c9590, state=..., modelTransformation=..., deltaRot=0) at Examples/AMDTTeaPot/AMDTTeaPotLib/src/AMDTTeapotOCLSmokeSystem.cpp:1656

#8  0x000000000041cab9 in AMDTTeapotOGLCanvas::paintWindow (this=0x6d02b0) at Examples/AMDTTeaPot/AMDTTeaPotLib/src/AMDTTeapotOGLCanvas.cpp:438

#9  0x000000000041c2a4 in AMDTTeapotOGLCanvas::onPaint (this=0x6d02b0) at Examples/AMDTTeaPot/AMDTTeaPotLib/src/AMDTTeapotOGLCanvas.cpp:155

#10 0x000000000040cdda in GLWindow::draw (this=0x6c4a20) at Examples/AMDTTeaPot/AMDTTeaPot/src/GLWindow.cpp:98

#11 0x00000000004231cf in Fl_Gl_Window::flush() ()

#12 0x0000000000425c12 in Fl::flush() ()

#13 0x0000000000425e5d in Fl::wait(double) ()

#14 0x0000000000425fad in Fl::run() ()

#15 0x000000000040c29f in main (argc=1, argv=0x7fffffffe2e8) at Examples/AMDTTeaPot/AMDTTeaPot/src/Teapot.cpp:500

As can be seen in the 'glxinfo' the system previous had GTX 980s in. I'm not sure if that's related. We'll be re-imaging the server without the NVidia driver installation step to see if that gets us around the issues.

The box, as it's installed, executes our OpenCL kernels without issue.

1 Solution

Hi Raymond,

Are you accessing this server via X-11 forwarding? If so, there is a known crash that should be fixed with driver 15.20.


View solution in original post

8 Replies

Hi Raymond,

Are you accessing this server via X-11 forwarding? If so, there is a known crash that should be fixed with driver 15.20.



Hi Doron,

I have the similar issue of this

In my notebook which with

APU: A10-8700P
Discrete gpu: Radeon R7 M360 ( this device looks like no have any driver with ubuntu/linux

After follow the guild of codexl , when I use terminal with "sudo ./CodeXL"

then I get the same error of


sudo ./CodeXL

./CodeXL: line 68: 6980 Segmentation fault (core dumped) /opt/AMD/AMD_CodeXL_Linux_x86_64_1.8.9654/./CodeXL-bin


Any idea to solve this problem?



Can you launch CodeXL from gdb, capture the callstack of the crash and share it? See example at the beginning of this forum thread.




Hi, dorono

Actually I don't know how to launch CodeXL with gdb...

because CodeXL file looks like a bash file cant not directly launch with GDB...

Can you teach me how to do it....?

my O.S. is Ubuntu14.04

cause when I command "gdb CodeXL", it said it is not a executable file for execute.



Hi cyhsu,

following is the procedure to generate call stack for the Seg Fault:

1. Open terminal in root mode

2. run "ulimit -c unlimited"

3. launch CodeXL

4. If it seg faults, we get a core dump in the same folder

5. Now, run "gdb ./CodeXL-bin core"

6. type "bt" (back trace). capture the call stack and send it to us


Kalyan P


I got


Reading symbols from ./CodeXL-bin...done.

[New LWP 4587]

[New LWP 4585]

[New LWP 4586]

[Thread debugging using libthread_db enabled]

Using host libthread_db library "/lib/x86_64-linux-gnu/".

Core was generated by `/opt/AMD/AMD_CodeXL_Linux_x86_64_1.8.9654/./CodeXL-bin'.

Program terminated with signal SIGSEGV, Segmentation fault.

#0  0x00007f8dd8e7ae2c in __GI___libc_free (mem=0x7ffc1be907e4)

    at malloc.c:2945

2945    malloc.c: No such file or directory.

(gdb) bt

#0  0x00007f8dd8e7ae2c in __GI___libc_free (mem=0x7ffc1be907e4)

    at malloc.c:2945

#1  0x00007f8de3f3bacd in ?? () from /usr/lib/

#2  0x00007f8de3f3b866 in ?? () from /usr/lib/

#3  0x00007f8de3f3b590 in amdPcsGetStr () from /usr/lib/

#4  0x00007f8dcc0725ba in ADL2_Graphics_Versions_Get ()

   from /usr/lib/

#5  0x00007f8de381602c in oaGetDriverVersion (driverError=@0x7f8dc7ffeac0: -1)

    at /data/jenkins/workspace/CodeXL-1.8-Linux/release/CodeXL/1.8/CommonProjects/AMDTOSAPIWrappers/src/linux/oaDriver.cpp:130

#6  0x00007f8de2b1f155 in afSystemInformationCommand::getSystemInformationDataAsString (this=this@entry=0x7f8dc7ffeba0, systemInformationStr=...)

    at /data/jenkins/workspace/CodeXL-1.8-Linux/release/CodeXL/1.8/CommonProjects/AMDTApplicationFramework/commands/afSystemInformationCommand.cpp:3065

#7  0x00007f8de2b1f3c0 in afSystemInformationCommandThread::entryPoint (


    at /data/jenkins/workspace/CodeXL-1.8-Linux/release/CodeXL/1.8/CommonProjects/AMDTApplicationFramework/commands/afSystemInformationCommand.cpp:51

#8  0x00007f8de3a83887 in osThread::threadEntryPoint (pParam=0x21cab80)

    at /data/jenkins/workspace/CodeXL-1.8-Linux/release/CodeXL/1.8/CommonProjects/AMDTOSWrappers/src/linux/osThread.cpp:76

#9  0x00007f8dd87d0182 in start_thread (arg=0x7f8dc7fff700)

    at pthread_create.c:312

#10 0x00007f8dd8ef247d in clone ()

    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

thanks for your help.



Hi CyHsu,

This appears to be the same crash as reported when accessing this server via X-11 forwarding. It should be fixed with driver 15.20 or later.

Which driver release are you using? Can you install the Radeon Software Crimson Edition driver and try again?



Hi Doron,

Still no work

Already try to install the lasted driver

my notebook:

APU: A10-8700P

Discrete GPU: Radeon R7 M260

O.S. : ubuntu 14.04 LTS 64bits

Already re-install of below website

1. fglrx_15.300-0ubuntu1_amd64_UB_14.01.deb

2. fglrx-dev_15.300-0ubuntu1_amd64_UB_14.01.deb

3. fglrx-amdcccle_15.300-0ubuntu1_amd64_UB_14.01.deb

and I cant find my discrete GPU driver from AMD, looks like only support in Windows O.S.