Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

CodeXL: Failed to merge temp files.

Hello !

I'm running CodeXL (CodeXL-Linux-1.1.1537.0-x86_64-release) with an Opencl program and I'd like to do profiling. What I've did:

    1.) erased the .amd directory

    2.) Paramterized the program and tested the command line execution without CodeXL - works OK

    3.) Created a CodeXL project applied the same parameters and environment variables for the executable

    4.) Set GPU Porfiling: Application trace

    5.) Set The "APIs to trace" to everything

    6.) Set the "Intervall at which to write...."  10 ms

    7.) Launched profiling

The program runs fine, it took 17 second but no profiling output comes, just this error message:

4/19 14:33:17: DEBUG: (main) Normal program termination. <<- Last line of the program
Failed to merge temp files.                                                 << - Error message
Failed to generate profile result /home/XXXXXX/.amd/AMD/CodeXL/XXXXXXXXXXX_ProfilerOutput/Apr-19-2013_14-33-01/Apr-19-2013_14-33-01.atp.
Failed to generate profile result /home/XXXXXXX/.amd/AMD/CodeXL/XXXXXXX_ProfilerOutput/Apr-19-2013_14-33-01/Apr-19-2013_14-33-01.occupancy.

Can somebody help finding the problem ? Do I miss anything ?

I've tried it on two differeent machine and gives the same result. I've checked and the re-created .amd directory is owned by me, writeable.

thanks in advance,


The system is:

[@build]$ uname -a
LinuxXXXXXXXX  2.6.32-279.1.1.el6.x86_64 #1 SMP Tue Jul 10 20:50:49 CEST 2012 x86_64 x86_64 x86_64 GNU/Linux

[XXXXX@XXXXX build]$ lspci | grep -i radeon
08:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Hemlock [Radeon HD 5900 Series]
08:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cypress HDMI Audio [Radeon HD 5800 Series]
09:00.0 Display controller: Advanced Micro Devices [AMD] nee ATI Hemlock [Radeon HD 5900 Series]

AMD appsdk version:


Tags (3)