cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

jimwu88
Journeyman III

clCompileProgram and clLinkProgram

When I compile a host code with SDK 2.9.1, the linker only complains undefined reference to these two API calls. I am using RHEL 5.9. Are these two APIs only available on RHEL 6.x?

test.cpp:(.text+0xe89): undefined reference to `clCompileProgram'

test.cpp:(.text+0xf1f): undefined reference to `clLinkProgram'

0 Likes
3 Replies
dipak
Staff
Staff

Re: clCompileProgram and clLinkProgram

Hi,

As per AMD_APP_SDK_Getting_Started_Guide1 for SDK 2.9-1:


The AMD APP SDK 2.9.1 is supported on the following Linux flavors:


OpenSUSE™ 13.1 (32-bit/64-bit)


Ubuntu® 14.04 (32-bit/64-bit)


Red Hat® Enterprise Linux® 6.x (32-bit/64-bit)


As I can remember, once I used these APIs using SDK 2.9-1 on RHEL 6.5 and both worked fine. Not sure about RHEL 5.9. Are you facing any problem on RHEL 6.x?

Regards,

jimwu88
Journeyman III

Re: clCompileProgram and clLinkProgram

Thanks Dipak,

Yes, both APIs work on a CentOS 6.5 VM. My main working machine is RHEL 5.9, it can be a hassle to ask IT to upgrade it. As I said, all other APIs work without any problem. Just curious if there is anything in the library actually checking OS version.

0 Likes
dipak
Staff
Staff

Re: clCompileProgram and clLinkProgram

Thanks for this confirmation. So, as recommended, please use RHEL 6.x.

I don't know the reason behind this OS dependency. But, it's an interesting observation. I'm also curious to know the reason. If get any answer, I'll share with you.

Regards,

0 Likes