cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

nou
Exemplar

Catalyst 10.10

finally OpenCL in driver

in new catalyst 10.10 there is OpenCL driver in it.

what about Linux? did i lose job ?

0 Likes
17 Replies
MicahVillmow
Staff

nou,
Please let us know if you have any issue with it.
0 Likes

Where is this 10.10 you speak of? Is it up for linux as well?

0 Likes

any issuse with what?

on linux i have no problem with 10.10 driver and my package. i did not have time try it on windows thought.

EDIT: to get linux change -9- in download link to -10-. but i can not find libOpenCL.so or /etc/OpenCL/vendors in Linux driver.

0 Likes

From the ReleaseNotes.pdf:

 

Introduction of AMD CatalystTM Accelerated Parallel Processing
("APP") technology Edition
There will now be two variants of the AMD Catalyst package available:
1. AMD Catalyst (comparable to prior versions in features and components) –
currently includes the Direct3D®, OpenGL®, display driver and AMD
Catalyst Control Center components
2. AMD Catalyst Accelerated Parallel Processing (“APP&rdquo technology Edition –
AMD Catalyst plus the OpenCL driver
Users can still obtain the individual AMD Catalyst components as well (which will
also include the OpenCL driver as well)

 

I'm confused... so users must choose between the TWO drivers? Why not only one type with all as NVIDIA does(physx, opencl,opengl,DX,all integrated)? Most users will be confused and they will download the first one, making your OpenCL apps not to run properly without downloading the SDK...

Sorry but I really I cannot understand that policy.... why an end-user would not want OpenCL installed? Most games are going to use it via Bullet Physics or directly ( as Just Cause 2 does with CUDA ). You really should integrate all as NVIDIA does : all in one driver and one unique download.

0 Likes
MicahVillmow
Staff

Thanks for the feedback bubu. I've let some people know of your concerns with the two packages.
0 Likes

This 10.10 release doesn't yet address any of the multiple gpu issues on linux, right?

0 Likes

Are the clc compiler and the opencl header files going to be included as well?

0 Likes

@bubu: they think that do not want download bigger driver. (that was argument why do not include OpenCL sometimes ago)

@gat3way: i do not try it on windows. but clc should be included as it necesery to compile kernels. headers file not as they needed only for development purpose so that cover SDK.

0 Likes
quadboon
Journeyman III

i have tested 5970 2nd GPU. still does not work 😞

0 Likes

The step to integrate the OpenCL.dll is nice but... please... remove the console window which appears on each clBuildProgram() call. I must compile like 20 different programs and the window is popping like mad

0 Likes
mux85
Journeyman III

is the version downloaded from steam the one with the opencl driver?

0 Likes

I have ATI Stream SDK installed already, but new update just installs its own copy into other directory (C:\Program Files\ATI Stream). Should I ignore the driver that goes with the update?

 

 

 

0 Likes

Originally posted by: datlatec This 10.10 release doesn't yet address any of the multiple gpu issues on linux, right?

 

 

It hasn't, at least in my tests.

 

0 Likes
MicahVillmow
Staff

bubu,
This is fixed in the next version of the OpenCL release. The 10.10 catalyst driver is using the SDK 2.2 OpenCL DLL, so not much has changed.
0 Likes

Trying to compile the 3rd example from ATI Stream Computing
OpenCL Programming Guide, but getting this:
error: can't enable all OpenCL extensions or unrecognized OpenCL extension
#pragma OPENCL EXTENSION cl_khr_local_int32_extended_atomics : enable
error: can't enable all OpenCL extensions or unrecognized OpenCL extension
#pragma OPENCL EXTENSION cl_khr_global_int32_extended_atomics : enable

Any chance it's driver-related?
My current driver is 10.10 APP technology edition.

0 Likes

i also tried to use these extensions in my application and got the same error. but with cat v10.10 and SDK v2.2 since there is no APP technology edition for linux 😞

0 Likes

Looks like those extensions are merely not supported by my 4850.

0 Likes