cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

lucasribeiro
Adept II

Cant debug HD7850

Jump to solution

Hi,

Could someone help me? My problem appeared after buying a HD7850 to replace my old HD6790. I can't debug using CodeXL anymore, it stops after "Building OpenCL Program" (Debugged process Events). The signal reason is SISSEG, address 00000000000000000 and Invalid memory reference.

Code hosted at lucasribeiroufrj/sph-project · GitHub.

Any help is wellcome,

Thanks,

Info retrieved using opencl/opengl API:

OpenGL Spec.:

  Version        : 4.2.12217 Compatibility Profile Context 12.104

  GLSL setted up : 4.20

OpenCL Spec.:

  Platform : AMD Accelerated Parallel Processing

  Vendor   : Advanced Micro Devices, Inc.

  Version  : OpenCL 1.2 AMD-APP (1124.2)

Device Spec:

  Name    : Pitcairn

  Vendor  : Advanced Micro Devices, Inc.

  Profile : FULL_PROFILE

  Version : OpenCL 1.2 AMD-APP (1124.2)

  Driver  : 1124.2 (VM)

OS information:

Linux  3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux (Ubuntu 12.04 )

Message was edited by: Lucas Azevedo
Added the code link.

0 Likes
1 Solution

Accepted Solutions
lucasribeiro
Adept II

Re: Cant debug HD7850

Jump to solution

I solved the problem updating the video driver from 13.4 to catalyst 13.8 and now I can debug!!

View solution in original post

0 Likes
3 Replies

Re: Cant debug HD7850

Jump to solution

On some cases with Linux machines after replacing a graphic card you might need to uninstall the driver and reinstall it. Please try it

0 Likes
lucasribeiro
Adept II

Re: Cant debug HD7850

Jump to solution

Thanks for answering.

I did that, I've reinstalled the driver and the SDK. After reinstall, I've tested some examples from SDK and everything went ok with them. Afterwards, I've tried to debug my application and the got a SISSEG.

0 Likes
lucasribeiro
Adept II

Re: Cant debug HD7850

Jump to solution

I solved the problem updating the video driver from 13.4 to catalyst 13.8 and now I can debug!!

View solution in original post

0 Likes