Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

Cannot find

Hey, I'm trying to run CodeXL on my Linux laptop with an nvidia gpu and their proprietary drivers so I'm not sure if this is the right place to ask, but here it goes.

I'm trying to debug an OpenGL program, but every time I try and run it I get an error about finding I found I have a copy in /usr/lib64/nvidia/, but for some reason CodeXL cannot find it. I tried making a symlink in the CodeXL directory with all of the other symlinks, but that hasn't helped things. I haven't been able to figure out why, does anyone have any idea what I can try to fix this? All I want to do is view some OpenGL buffers.

2 Replies

CodeXL is looking for the using the env variable LIBGL_DRIVERS_PATH.

Usually if the path defined there is /usr/lib/subdir then CodeXL expects to find the & libOpenGL in /usr/lib (one directory upward)

You can either define that env variable manually or put those libraries to where it is defined as I pointed above

I hope this helps

Setting LIBGL_DRIVERS_PATH to something one deeper than where is stored didn't seem to work (I tried /usr/lib64/nvidia/xorg, but CodeXL was still unable to find it). However, following your second suggestion to simply symlink it (I symlinked it to /usr/lib64) seemed to make things work.

Thanks you so much for this! Now I can finally get back to trying to see what's wrong with my code.