cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

gabest
Journeyman III

Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

The GPU is a R9 270X with the just released driver (14.501.1003-141120a-178000C, 14.12) on Windows 8.1.


When I run the SDK samples:


Platform 0 : Advanced Micro Devices, Inc.

Platform 1 : Intel(R) Corporation

Platform 2 : Intel(R) Corporation

Platform found : Advanced Micro Devices, Inc.

Selected Platform Vendor : Advanced Micro Devices, Inc.

Device 0 : Pitcairn Device ID is 0000008F4C7E73D0

Expected Error: Unsupported device! Required CL_DEVICE_OPENCL_C_VERSION 2.0 or higher

Attached the output of clinfo. It still says 1.2.

I'm pretty sure it should be a supported configuration, but it just does not want to work for me since the beta driver 14.5.

0 Likes
1 Solution

Accepted Solutions
dipak
Staff
Staff

Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

I guess, R9 280X is Southern Islands (SI) based which doesn't support OpenCL 2.0. OpenCL2.0 is supported for Sea Islands and higher cards.

Regards,

View solution in original post

0 Likes
11 Replies
jvsala
Adept II

Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

As the output says, your device is not supported.

"Device 0 : Pitcairn Device ID is 0000008F4C7E73D0

Expected Error: Unsupported device! Required CL_DEVICE_OPENCL_C_VERSION 2.0 or higher"

Older GCN cards don't support OpenCL 2.0. For a comprehensive list check:

List of AMD graphics processing units - Wikipedia, the free encyclopedia

The list can be a bit confusing. You should check the codename. Pitcairn is the chip used in the 7850 and 7870 cards. Your card seems to have the older chip instead of the newer Curaçao which does support OpenCL 2.0.

I think the first 270 and 270X cards were rebadged 7850/7870.

0 Likes
tqian
Adept I

Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

R9 270(x) is not supported. I am slightly disappointed by the news as well:

OpenCL™ 2.0 conformance logs submitted (pending ratification) for: AMD Radeon HD 7790, AMD Radeon HD 8770, AMD Radeon HD 8500M/8600M/8700M/8800M/8900M Series, AMD Radeon R5 M240, AMD Radeon R7 200 Series, AMD Radeon R9 290, AMD Radeon R9 290X, A-Series AMD Radeon R4 Graphics, A-Series AMD Radeon R5 Graphics, A-Series AMD Radeon R6 Graphics, A-Series AMD Radeon R7 Graphics, AMD FirePro W5100, AMD FirePro W9100, AMD FirePro S9150.

http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/syst...

You can see the only R9 cards that support 2.0 are 290 and 290x.

ekondis
Adept II

Re: Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

What about Tahiti? The list you referred lists the "Radeon R9 280X" as an OpenCL 2.0 capable device whereas the "Radeon HD 7970" as an OpenCL 1.2 only device. AFAIK, they are both based on the same silicon.

The official OpenCL 2.0 device list should be more clear.

0 Likes
jvsala
Adept II

Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

What I understand from the list is that there exist later revisions of Tahiti that DO support OpenCL 2.0, but the former models don't. Sadly, I think you can't know without checking the device identifier in each card.

0 Likes
jvsala
Adept II

Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

The cards that without doubt support OpenCL 2.0 are the 7790, R7 260/X, R9 285 and R9 290/X.

gabest
Journeyman III

Re: Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

Thanks guys, I think I confused R7 200 series with R9 200 series on the list. Pretty disappointing indeed. Just bought it a couple of month ago hoping for an "upgrade".

0 Likes
tqian
Adept I

Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

I agree - I find the official statement a bit weird too: if all R7 200 cards are supported, which means that R7 250, which is rebranded 7750 GCN 1.0, is supported, what is preventing R9 270 from being compatible with OpenCL 2.0?

0 Likes
nan
Adept II

Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

Hi,

does anybody know whether R9 280X has OpenCL 2.0 support with Catalyst 14.12? When I tested the OpenCL 2.0 beta driver only my R9 290 (not the R9 280X) had working OpenCL 2.0 support.

-- NaN

0 Likes
dipak
Staff
Staff

Re: Can't get any opencl 2.0 samples run from the latest 3.0 SDK.

Jump to solution

I guess, R9 280X is Southern Islands (SI) based which doesn't support OpenCL 2.0. OpenCL2.0 is supported for Sea Islands and higher cards.

Regards,

0 Likes