cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

akilan
Journeyman III

CAL Version mismatch

Hi

 

I recently installed ATI stream vSDK2.0 in my laptop having ATI Radeon mobility HD 4570.

It installed properly. But when I started running an OpenCL program it throws the following error,

 

****CAL Version mismatch

This openCL build requires version 1.4.467.

Version 1.4.344 installed aborting clGetDevicesIDs Failed

 

Suggest me to get out of this problem.

 

Thanks

0 Likes
5 Replies
omkaranathan
Journeyman III

Seems you are having old drivers.

You need to install recommended display driver available at

http://support.amd.com/us/kbarticles/Pages/ATICatalyst912Hotfix.aspx 

to be able to run OpenCL.

 

0 Likes

I installed ATI Catalyst 9.12 hotfix. But still I m getting same error.I wud like to know whether  ATI Radeon mobility HD 4570 supports GPU computing?

If it is supported, what I need to do for fixing such error?

0 Likes

Originally posted by: akilan I installed ATI Catalyst 9.12 hotfix. But still I m getting same error.I wud like to know whether  ATI Radeon mobility HD 4570 supports GPU computing?

If it is supported, what I need to do for fixing such error?



If you still get exactly the same error:

****CAL Version mismatch

This openCL build requires version 1.4.467.

Version 1.4.344 installed aborting clGetDevicesIDs Failed



You don't have a correctly installed Catalyst 9.12 driver. That would be CAL Version 1.4.5xx (don't remember exactly).

0 Likes

I get the same error. I don't have a GPU on my system, but I am trying to compile the OpenCL examples for my dualcore AMD laptop CPU. Any help appreciated.

Thanks.

0 Likes

Zenci, 

Please post the exact error message you are getting. Also OS, SDK, Sample you are running etc. Also, did you use the '--device cpu' option while running the sample?

0 Likes