cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

dert
Adept I

Bug in Catalyst 12.4

Hey folks, just got notified to update my Catalyst for my ATI Radeon HD5700 series so I did (Version 12.4 Dated 4/29/2012).  Interesting problem popped up right afterwards.  My card is attached to my flat screen TV (I'm using the PC as a media center) via an HDMI cable.  When I turn my TV off for the night and back on again in the morning, I have no audio from the PC over the HDMI cable!  The audio properties show the HDMI cable to be unplugged but clearly it's not since I'm reading it on the screen.  If I unplug and plug the HDMI cable back in, voila!  Sound is back.  I have to re-seat the cable for this to recover, I've tried disabling and enabling the device, defaulting to external speakers via RCA cables into the motherboard etc....cable has to be unplugged and plugged back in again.  It's not the flat screen, I tried using different HDMI ports on it (I've got 3) and my PS3 and whatnot run just fine with all 3 ports.  It's not the Radeon hardware, the video and sound work just fine after re-seating the cable.  The problem started immediately after your last driver update so I'm quite sure that's where the problem lies.  I believe it's some kind of "sleep" issue??  In another words, for some reason when the external HDMI receiver powers off, Catalyst now treats that as "unplugged" and only the audio cannot recover properly when the device powers back on.  Take a peek please and let me know what you find.

71 Replies
dert
Adept I

Re: Bug in Catalyst 12.4

I just did a system restore to 4/24, prior to the installation of the new 12.4 driver, on my Windows 7 x64 system.  With the previous version of Catalyst, the problem with the HDMI audio dying after the flat screen panel is turned off has disappeared.  It's definitely the new driver.

rakkakaze
Journeyman III

Re: Bug in Catalyst 12.4

I am having the same issue, specifically it's when Windows goes into the "sleep" mode to stop transmitting data to the monitor that this issue arises.  I notice immediately because I almost always have music playing and it switches over to the only remaining output which is my headset.  No other measure aside from downgrading will resolve this problem aside from unplugging and plugging the HDMI cable back in (which is quite a pain if you are setup to not mess with the back of any of your equipment)

0 Likes
stoneroses
Journeyman III

Re: Bug in Catalyst 12.4

Same here, unplug and plug back in. I have to get up and do it lol. They gone old school on us!

0 Likes
comedyink
Adept I

Re: Bug in Catalyst 12.4

Also having this same issue when I updated from 12.3 to 12.4, I thought that it maybe it was a problem my Microsoft Xbox Wireless Receiver, but apparently it's not.

Windows 7 x64

HD5870 running via HDMI

0 Likes
amnix
Journeyman III

Re: Bug in Catalyst 12.4

Completely analogous to the problem. I have a graphics card HD6870. Updated driver to version 12.4. After updating, when the monitor goes into power saving mode (the monitor with speakers, connected by HDMI), lost the sound on the monitor (in the Manage Audio Device - Sound - says that the device is AMD HDMI Output is not connected). After rebooting, the monitor sound is restored, until such time as the monitor will not go back into sleep mode.

Windows 7 x64 - HD6870 - running via HDMI

0 Likes
cccccc
Adept I

Re: Bug in Catalyst 12.4

same issue here with ATI Radeon HD 5700 Series

reverted back to 12.3 until a patch comes out.

0 Likes
gramin
Journeyman III

Re: Bug in Catalyst 12.4

Registered for these forums to echo the same frustrations as everyone above. 12.4 is also causing my sound to disappear when my monitor or TV is shut off.

0 Likes
mefyrx
Journeyman III

Re: Bug in Catalyst 12.4

I was gonna post the same issue here

Windows 7 Ultimate 64 bits English

I have a Sony Bravia 46'' tv

Since i've put the 12.4 driver, i've bin having the issue where the HDMI audio would be offline in my list.

I'm using 2x Radeon 5770 in crossfire

The only way to make the sound apear is to unplug the HDMI cable and plug it back in, or just activate or deactivate the crossfire, since it allow the card to look again for connection and then the card figure out that theres an audio channel

Then if i would change my tv input to something else than the HDMI-CPU connection, minutes later it would go offline, or if i would switch back to the HDMI-CPU input, it would go immediatly offline.  Then i would have to do the hole thing again...

I wasn't sur it was the issue since i,ve done a bunch of change, so i've done a clean install of Windows 7, then Windows did it's automatic updates and installed their driver for the ATI, after rebooting, everything was still working.

I've installed 12.4, immediatly after that, i ran in the same issue

So i've reinstalled Windows 7 again and installed back 12.2 and i'm ok

(I'd rather have a cleaned installed than downgrading drivers)

I know in the installation package, theres something named HDMI something and the version is a bit different, minor change in the number.  Perhaps they did tried to put the HDMI sound connection offline when your TV is not oppened or not on the CPU-HDMI input, so for those that had the HDMI audio by default would immediatly switch back to the next audio connection avaible so that you always get a channel ready

...in 12.2 we don't have the issue because the HDMI audio channel is always on even though it's not connected to the right input...so if you have it as the default audio, you won,t hear anything while it's not connected...and you'll have to change your audio output to your cpu speaker for exemple...

It's a good idea but i think they need to work on that....even better because K-Lite is doiing the same if the HDMI output is not there, it's gonna go back to the default channel....then if you open K-Lite with your HDMI channel ready, your HDMI default is automaticly back....

0 Likes
TheyDroppedMe
Journeyman III

Re: Bug in Catalyst 12.4

Disable the "AMD External Events Utility" in services.msc

This has worked for me.

0 Likes