Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

Brook, Brook+

problems and incompatibility

I'm working on a hobbie-project which needs the power of the GPU. But it is definitely no solution, if it runs only on AMD or NVIDIA.

So I tried Stanford Brook(v0.5) at first, because it runs on both NVIDIA and AMD. AMD Brook+ does only support AMD-GPU's as far as i know...

The problem: flex bison plaplapla, after much more then an hour, flex and bison worked, but then it needed unistd.h, I told the IDE the path to the include-folder from Codeblocks and Cygwin(I tried both), now there are 42 errors, telling me that "include_next" is no präprocessor-command.

There is no binary release in the whole internet, so before giving up, I tried Brook+ because I have got a X1950Pro(AGP). But Brook+ goes leap ahead: There are binaries. I tried to run the samples, they didn't work, I tried to compile the samples, it doesn't work because brcc.exe crashes.

I tried with Visual Studio 2008. I would be glad if someone knows the solution here, can somebody maybe send me the binaries from Stanford-Brook? I'm pretty sure that there are many programmers which would be glad when someone would upload a working project or working Brook-binaries.

(sorry for my english, I come from Austria)



No way to compile the brcc.exe...

Tried many things but there are nearly 100 of errors......

And in debug-mode there are just some problems with the debugdatabase. But Im pretty sure that there will be new problems when this problem is fixed......

I will give Lib-Sh a try now.


0 Replies