cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

cyseal
Adept III

Blender OpenCL support - binding GCN 1.0 and GCN 2.0 on driver level ?

Is it possible to combine these two architectures on software/driver level ?

Basically, could GCN 1.0 card operate within the driver like GCN 2.0 card?

0 Likes
3 Replies
dipak
Staff
Staff

Re: Binding GCN 1.0 and GCN 2.0 on software/driver level ?

Though some features may work but overall I don't think it's likely to happen due to the architectural limitations that 1st generation GCN cards have compared to 2nd generation cards.

Regards,

gstoner
Staff
Staff

Re: Binding GCN 1.0 and GCN 2.0 on software/driver level ?

First GCN 2.0 is a superset of capabilities beyond GCN 1.0.   GCN 1.0 is also only compatible with OpenCL 1.2.  GCN 2.0 is compatible with new feature specified in OpenCL 2.0 spec.   So to get to answer your looking for if you develop an OpenCL 1.2 program it will run on GCN 1.0, 1.1, and 2.0 enabled GPU's.  We JIT the program from OpenCL source to proper GCN machine instructions for you.

cyseal
Adept III

Re: Binding GCN 1.0 and GCN 2.0 on software/driver level ?

Blender no longer supports my card AMD 7870. I can't select Pitcairn OpenCL anymore due to unsolvable issues in the compiler which Blender developers have.

Is there is some solution to rewrite the drivers for 7870 so that I could be able to use it

pitcairn.JPG

0 Likes