cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

timchist
Elite

AMD OpenCL runtime conflicts with Intel's

Jump to solution

Hi all,

I'm using an Intel i7 3770K CPU that has an integrated GPU with OpenCL capabilities (HD Graphics 4000). OpenCL support is built into the graphics driver from Intel. I also have a discrete GPU -- AMD HD 7970 supporting OpenCL, this support also implemented in a driver (this time AMD's).

The problem is that after I install the AMD's driver Intel's GPU is no longer accessible via OpenCL. There are two OpenCL platforms present in the system, but the Intel's one only sees CPU (AMD's sees both CPU and GPU). Before the installation of the AMD driver Intel's platform sees two devices: the CPU and HD Graphics 4000.

Is it a known issue?

Regards,

Tim

0 Likes
1 Solution

Accepted Solutions
timchist
Elite

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

Managed to make it all work too with Catalyst 13.1-13.6beta and Intel 9.18.10.3071 driver.

View solution in original post

9 Replies
himanshu_gautam
Grandmaster

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

Probably there is one more thread complaining similar issue, so I am planning to set it up once again.

Anyways can you confirm that intel's iGPU is set as the primary Video Adapter in your BIOS.

Can you give information about platform: Operating System, Bitness, and the Driver versions used (for intel and AMD).

0 Likes
timchist
Elite

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

Thanks Himanshu.

Intel's GPU is indeed set up at the primary GPU in bios. There is only one monitor and it is connected to the output of Intel's GPU (I am aware that it's a requirement of Intel's OpenCL implementation). AMD adapter is only used for calculations and is working in headless mode.

Operating system is Windows 7 64-bit. Driver version: Intel - 9.17.10.2932, AMD - 9.12.0.0 (came with Catalyst 13.1). Motherboard is Gigabyte GA-Z77X-UP7.

0 Likes
himanshu_gautam
Grandmaster

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

btw, "clinfo" does not work well if both OpenCL 1.1 and OpenCL 1.2 platforms are mixed.

A fix is under progress.

Does "clinfo" exit with proper error status?

I suggest you may want to just write a small application to query your platforms and see if everything is returned.

OR Just at least return the platform count first.

0 Likes
timchist
Elite

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

clinfo is exiting with 0. I also checked GPU Caps Viewer, samples from Intel OpenCL SDK, as well as to run my own program that simply tries to get GPU devices under Intel OpenCL platform. All of listed above consistently report that there is only one device under Intel's platform and that this device is a CPU.

Before installing AMD driver everything was working correctly (except clinfo that was not present in the system).

UPDATE: just to clarify, platform count returns 2. Under AMD I see two devices: HD 7990 and the CPU, under Intel just one device: the CPU. When AMD driver is not installed, I only have one platform (Intel), under which there are two devices: the CPU and HD Graphics 4000.

0 Likes
himanshu_gautam
Grandmaster

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

Is the intel GPU driving the windows console? I am just curious. Looks like, the intel graphics driver is not loaded..

0 Likes
timchist
Elite

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

Yes, Intel is the only adapter that is used for displayed purposes in Windows. Monitor is only connected to it. Intel driver seems to be active, all Intel-specific tools, control panel applets, and settings dialogs are working normally. In addition, OpenGL and 3D acceleration is working properly.

0 Likes
peterwishart
Adept I

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

Hi Tim, I'm having a very similar issue (with a sort of workaround on Windows 8, but may apply to 7): http://devgurus.amd.com/thread/160466

I have in the past managed to get the Intel OpenCL driver resuscitated after this happens by doing various things which may include (I never narrowed down the exact steps...):

  • Editing the path to put AMD entries prior to System32 etc. at the end of the path (probably not relevant)
  • Reverting the HD4000 driver to the WDDM driver (basic windows update default)
  • Uninstalling any manually installed intel graphics drivers/software
  • Reinstalling the latest .2932 Intel driver

Also I think I found that the requirement for having the monitor attached to the IGP was only when installing the Intel driver for it, might be wrong on that though.

0 Likes
himanshu_gautam
Grandmaster

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

Hi,

I have created this setup and I did iGPU without any issues. Check details here http://devgurus.amd.com/message/1288165#1288165

Hope this helps.

0 Likes
timchist
Elite

Re: AMD OpenCL runtime conflicts with Intel's

Jump to solution

Managed to make it all work too with Catalyst 13.1-13.6beta and Intel 9.18.10.3071 driver.

View solution in original post