cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

derpderp
Journeyman III

AMD GPU clock tool freezing.

Problem with 5650 mobility on the envy 14

Here is a gpu Z of said GPU : http://i169.photobucket.com/albums/u209/magusdraco/gpuz.gif

The versions of clock tool tried, all crash the same :

http://www.techpowerup.com/downloads/1641/AMD_GPU_Clock_Tool_v0.9.26.0_For_HD_5870.html

http://downloads.guru3d.com/AMD-GPU-Clock-Tool-v0.9.8-download-1985.html

The problem is that the AMD clock tool (the 5870 version) hard freezes (no error message) and crashes whenever it is launched. Several catalyst versions were tried (10.3 supplied by hp, and 10.6 and 10.7 beta from ATI).

The same card on another laptop (acer 3820TG or sony viao E) does not crash with AMD clock tool.

May it be an issue with how the program tries to recognise the card bios ? Or does the problem lies elsewhere ? Like the device ID ?

I was wondering if AMD clock tool could be fixed somehow.

A lot of envy 14 users are in need of this program to get the GPU to normal stock clock, the current cards are underclocks at 450mhz instead of 550mhz. So far only MSI afterburner manages to overclock this card.

If anyone has a tip about how to fix AMD clock tool, or get rivatuner to work, or any other program, or hell even about how to flash the Vbios. Your help would be appreciated.

 

 

0 Likes
1 Reply
Byron
Staff
Staff

AMD GPU clock tool freezing.

I'm not sure how that internal tool that requires an NDA got to that website but there is no support available unless approved by AMD and an NDA is signed.

0 Likes