Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

AMD gDEBugger kernel uses unsupported features

I'm trying to debug a basic kernel, but every time I start gDEBugger it reaches the kernel and throws a warning saying "Could not debug kernel. This kernel uses unsupported features. Please check the release notes for more details."

As far as I can tell, my kernel isn't doing anything wrong according to the release notes.

This is the kernel I have:

kernel void polypoints(global float* global_coeffs, local float* coeffs, const int num_coeffs, global float* results, const int num_results, const float start_t, const float delta_t)


for(int i = get_local_id(0); i < num_coeffs; i += get_local_size(0))


coeffs = global_coeffs;


float t = start_t + delta_t * get_global_id(0);

float ans = 0;

for(int j = 0; j < num_coeffs; ++j)


ans += coeffs * pown(t,num_coeffs - j - 1);


if(get_global_id(0) < num_results)


results[get_global_id(0)] = ans;



What's going on? I took the getting started guide's advice and didn't modify my code at all. Do I need to add some compile options (I think in the past there were some compiler flags for debugging opencl code using gdb)?

By itself the kernel compiles and runs.

6 Replies

Hi helloworld922, Can you please share your system information?

What graphics card do you use, driver version, OS and APP SDK version?


I have a HD5650 mobility card on an Acer Aspire (I can't quite remember the exact model number). I'm running it under 64-bit Windows 7 with AMD APP SDK 2.6, the 64-bit version of gDEBugger 6.1, and I believe the graphics card driver is 12.2 (not quite sure on the last subscript, it's the latest one released updated about a week ago or so). I'm debugging under Visual Studio 10 with SP1 installed. I tried debugging it with both 64-bit debug/release builds.


Please try removing the const modifiers from the kernel arguments. gDebugger currently doesn't handle these correctly with the Catalyst 12.2 driver. You could also try sticking with the Catalyst 12.1 driver. This issue will be resolved in the next release of gDebugger.

Journeyman III

I have the same problem. I am using HD5830 desktop card, Windows 7 64 bit, Visual Studio Ultimate 2010. No matter wheter I am using Catalyst 12.1 or 12.2 driver I got he the same warning as in original post. Kernel itself is working fine. It is just that I can not step into it.

Journeyman III

I managed to get back to a configuration that allowed me to debug kernels.

In one of my earlier posts, I said that I had re-installed windows and it didn't help. That time, I installed an older version of the APP SDK and Catalyst 12.3. After that didn't work, I removed the drivers and installed 12.1, but that didn't work either.

I did another re-install, but this time I installed 12.1 first, and then it worked!

So I am currently using Catalyst 12.1 and AMD APP SDK 2.6 with a working gdebugger.

I fear that installing Catalyst 12.3 changes something that breaks gdebugger, and whatever it has done isn't undone when you remove it.

Adept II

Hi everybody,

I have the same, identical problem. And I have the same pc settings as helloworld922.

I'm programming under VS2010 with gDebugger inside it (VS2010 extension, version 6.1.76, previously I used external gDebugger, 6.2 version). I was working with ADM APP SDK 2.8, then I downgraded to 2.6 version. I was working with Catalyst 13.9 release (installed driver version: 13.125....), then I downgraded to different releases: 13.5, 13.4, 13.1, 13.2beta, and maybe one more, actually I don't remember. I've tried many times to uninstall everything, and then reinstalling first Catalyst drivers, then SDK. But everytime the same error: "could not debug the kernel, unsupported features". Without debugging, everything works fine.

Working with the gDebugger tool 6.2 version standalone (outside VS2010) gives me another strange error: "CL_INVALID_COMMAND_QUEUE". Anyway, without debugging, everything works fine, as usual.

Platform configuration: Acer Aspire 8943G

GPU: ATI Mobility Radeon HD 5650

CPU: Intel core i7 720QM

OS: Windows7 - 64bit

@ Lihan Bin: do you mean removing the const qualifier from the kernel input and in the declaration of variables inside the kernel function? [example: __kernel void hello(__global *float input, CONST int N, CONST float j]

In that case, I did. No success.

Hope to fix the problem asap.