Showing results for 
Search instead for 
Did you mean: 

Archives Discussions


AMD APP SDK 3.0 Beta now Available

The AMD APP SDK 3.0 Beta is available.

Having explored the potential of OpenCL 2.0 via provisional OpenCL 2.0 drivers and our OpenCL 2.0 Demystified blog series, you can now dive deep with AMD’s latest offering: official OpenCL 2.0 drivers and a beta version of the AMD APP SDK 3.0.

That’s great! What does it contain, and why should I care?
AMD APP SDK 3.0 Beta provides samples that illustrate all the major new features of OpenCL 2.0 and a glimpse into the most interesting optional features. These features are already supported on recent APUs and GPUs from AMD (for a full list of supported products, see here), so you can start programming and deploying software with OpenCL 2.0 today. AMD APP SDK 3.0 Beta also supports the Bolt 1.3 library and includes new samples for the Bolt C++ AMP library.

AMD APP SDK 3.0 Beta also provides a new, web-based installer that allows you to download only what you choose, but still distribute the downloaded package locally.

Finally, AMD APP SDK 3.0 Beta includes enhanced documentation. The Getting Started Guide has been restructured to provide quick and relevant information to Windows and Linux users. The FAQ has been updated to include answers to the most pressing questions on OpenCL 2.0. The AMD OpenCL programmer’s guide – the most useful reference manual for OpenCL users – is now repurposed into two documents: the AMD OpenCL user’s guide, containing relevant OpenCL information for basic users; and the AMD OpenCL optimization guide, containing optimization guidelines for advanced users. The AMD OpenCL user’s guide has been revamped with a host of improvements (read about the improvements and provide feedback here), and the AMD OpenCL optimization guide features important updates.

That IS something! I can’t wait to get started.

Neither can we.

All said, it’s still a Beta.

And, be advised...there is one hiccup we're aware of. The Catalyst driver version 14.12 does not support OpenCL 2.0 on FirePro Graphics cards.

To work with OpenCL 2.0:

* On Radeon graphics cards, use the Catalyst Driver linked to above.

* On supported FirePro graphics cards, use the early-release driver available here. That page details the particular cards that are supported.

Your feedback will help us define and improve the quality of our GA offering.

15 Replies
Adept II

Good! but

1. Where's the app to precompile kernels into SPIR opcodes pls?

2. No fine-grained SVM support yet?

3. I specify an installation path ( d:/AMDAPPSDK ) but the installer ignored it and copies a lot of things into c:/program files(x86)/AMD APP SDK.



Pending a more detailed answer from Dipak or someone on SPIR...

Marty Johnson's overview of the new APP SDK has a list of the examples included. On that are

* SVM Fine Grain Buffer + Platform Atomics

* SVM Fine Grain Buffer + C11 Atomics - requires Linux APU

I believe there will be a blog article demonstrating fine-grain SVM in the near future, probably January given holidays, but no promises. It's in the works, but sometimes things that are planned don't see the light of day.

I'll get the installer feedback to the team.



1) If you are looking for a SIPR generator, you can use any standard SPIR generator like CLANG [KhronosGroup/SPIR · GitHub]. AMD compiler fully supports consumption of SPIR. You may check the SDK sample "SimpleSPIR" to see how to consume SPIR code using OpenCL API.

2) Already answered.

3) When the installation path is changed, it changes the samples installation path. So the samples, which generally go into the %USERPROFILE% directory as of now would go in the d:/AMDAPPSDK directory. The contents of Program Files (x86) are the AMDAPPSDKROOT contents, which as of now cannot be changed via the UI. However if you need to write the AMDAPPSDKROOT contents to a non-standard folder, then the SDK installer can be run from the command line as follows:

AMD-SDKInstaller-v1.2.116-Beta-windows-F-x64.exe /v”INSTALLDIR=d:\AMDAPPSDK”



1) I would prefer to use a command-line tool from AMD ( like the NVIDIA's nvcc.exe compiler ) or the Intel's IOC tool, honestly !

2) Apparently, OpenCL 2.0 SVM fine grained with atomics full support is currently only available on Kaveri APUs and CPU devices. Not for Radeon 7XXX and neither 2XX GPUs.

We would like to know if they will be full SVM-compatible, thx!

3) Thanks for the turnaround, it worked well. I would rather prefer to install ALL into the dir I specify. I don't like to install SDKs into my C drive(specially into the Program Files dir because it contains spaces and also the x86/x64 problem, some old programs will have problems with that ).

1) Sorry, we don't have any such tool. Please use any publicly available standard SPIR generator for this purpose.

2) Cannot comment right now.

3) Nice to hear that it served your purpose.


Adept III

Does Catalyst Omega actually have Opencl 2.0 drivers for R9 290X cards...

Mine is reporting 1.2

You can also see this here



cl_driver_version1642.5 (VM)
device_versionOpenCL 1.2 AMD-APP (1642.5)

does it work for Crossfire'ed cards?


Are you building your app as 32 bit app? It looks like only 64bit OCL library is 2.0. When I built the samples as 32bit executable, I got the same problem.



Is there a 64bit version of clinfo?

Also note to AMD. the new clinfo crashes when enumerating Intel openCL 2.0 devices


clinfo AMD ships with their catalyst driver is 64bit. The data from ozone3d site is produced using their GpuCapsViewer, which I think is available in 32 bit only. On my PC (Kaveri, Win8.1 x64), clinfo show OCL2.0 for GPU but GpuCapsViewer shows OCL1.2 for GPU.

Do you have both Intel OCL and AMD catalyst installed on your machine? I only have AMD OCL on my PC. Maybe having both installed is causing issues?

Adept I

I can provide a minor bug report already:

The 64bit linux installer has the following problem: after installation is finished,

1) the icd file is incorrectly added to /etc/OpenCL. It should be /etc/OpenCL/vendors.

2) the environment variable setting file in /etc/profile/ incorrectly sets the opencl vendor directory to INSTALATION_PATH/etc/OpenCL/vendors. It should be just /etc/OpenCL/vendors

For 1), the symptom will be that "clinfo" can't find the AMD CPU driver at all. For 2), after a reboot, "clinfo" will report no usable platforms on the computer, because it's looking in the wrong place.

I had similar problems installing on 64 bit windows 7.

No device was found after reboot.

I have rolled back to 14.8.

Adept II

how do you reinstall it?

i had to quit the installer in the middle and when i try to reinistall it, i get this wierd error

APP SDK 3.0-0 Beta is already installed on this computer. This wizard will not install APP SDK 3.0-0 Beta. I tried uninstalling it from the control panel (win 7) and no variation works. I can only reinstall the media library.

i am guessing the installer is messing up some registry keys somewhere. shouldn't there be an option to just reinstall?


I would like to submit a feature request for the final version of SDK 3.0.

Please clean up and update the cl.hpp that ships with the SDK. I very much hate the C API of OpenCL due to it's verbosity. The C++ bindings help to some extent, but some cl::Device::getInfo() versions are missing, such as CL_DEVICE_IMAGE_MAX_BUFFER_SIZE. Also, please remove the monstrosity around the kernel functors emulating variadic macros. The LoC count is crazy and Visual Studio has had implemented proper variadics for quite some time now.

cl.hpp is an extremely useful utility wrapper. Please update it to OpenCL 2.0 and proper variadics.


I think it's a Khronos issue, but yes, I'd love a new cl.hpp too.


In an ideal world it would be, but AFAIK the cl.hpp was developed by AMD for their own SDK, and Khronos only hosts the headers for convenience, but it is not part of the standard. As you can see, the provisional spec of OpenCL 2.0 has been around for more than a year, and still no C++ bindings for that. That is because AMD has not updated their headers yet. That is why I asked.