Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

AMD APP and OpenCL

Hello everyone -

I am new to the forum after calling AMD for support. They recommended I ask the question here. Here is my issue that is driving me crazy.

Many applications I attempt to use APP within (For instance IMToo DVD Ripper, Aiseesoft products etc) do not allow the use of the technology. While my configuration seems to be accurate, 8 for 8 differing photo/video software programs are telling me that I either need to update my drivers or that my card is not supported. In other words, the option to use nVidia CUDA and AMD APP are always gray and unavailable for selection.

I don't get why this would happen given all the recent drivers and having a supported card coupled with an AMD based system. It has to be something with OperCL. Any direction or ideas?


Board - ASUS M5A99X EVO

CPU - AMD FX-8120

GPU - AMD HD 6770

RAM - Corsair Vengeance 16GB 1600

All current media codec, OpenCL and catalyst drivers are installed.

8 Replies

Are you able to run clinfo from the AMD APP SDK? If that correctly detects your driver/device and dumps information, then the problem is in the application as the OpenCL software itself is working.


I ran clinfo in a cmd window and got back inormation about my devices. Pardon my green nature here but how can I run from SDK? What am I looking for exactly. I wonder if we have issues with the applications not being 64 bit and the OS and opencl drive is....



If clinfo is returning the correct information about the devices on your system, then the problem is with the applications or some incompatibility on your system. If you can post more information on what your setup is, what command you are trying to run, and what your error is we could be able to help. Also, information on what 'relevant DLL's are in your system path would be helpful.


Sure thing.

I have dual Radeon 6770's (did not work with one either) and I am simply trying to utilize the AMD APP function avaiable in Aiseesoft DVD Ripper. (and other programs like it) I know I have "amdocl64.dll" on the system however I am not sure what I would need to do to get these applications to see that I do indeed have APP available on my card for use. This is really greek to me but I would really like to get it working. I have done a lot of reading and settings in CCC and drivers required on the AMD site have been installed.

Sorry I wish I could be more helpful here.


I would recommend uninstalling the AMD APP SDK, uninstalling the driver, using a driver cleaner to make sure that nothing is left behind(make sure that no atical*.dll amdcal*.dll amdocl*.dll exist in either System32 or syswow64) and reinstall just the graphics driver. There might be a weird issue with SDK and driver causing some problems interacting with each other.

If it still doesn't work, try downloading some recently released OpenCL benchmark and running that. This seems like it might be an application problem and not a driver/runtime problem, but we need to make sure first.


Thansk again.

While none of that resolved the application issue, I did run DirectCompute OpenCL benchmark. Indeed - all seems well and in fact, it was utilizing both cards. Worked out in the benchmarck so I wonder why all these applications don't see that? May very well be related to the 64 bit OS I am running these apps in.


Well - No go on the 64 bit theory. Ran in Win7 32 Bit enviroment and notta there either. Odd too as I have a MB Pro with Win7 32 Bit on it with nVidia CUDA abilities. The same app lets me enable CUDA on that machine.

I am fresh out of ideas.


I was going to say it shouldn't matter: i've run the same JOCL java application in a 32 bit or 64 bit jvm and the opencl stuff worked just fine with amd or nvidia drivers installed; it installs both interfaces everwhere i've done it.

Your best bet is asking the vendors of the software in question: maybe it just isn't supported, they have bugs in their device discovery, or they can suggest some diagnostic mode to trace the problem.