Showing results for 
Search instead for 
Did you mean: 

Archives Discussions


AMD A8 3870K Black Edition and AMD Radeon HD 7750 in Linux

I recently bought for my lab four systems each containing an AMD A8 3870K Black Edition and and AMD Radeon HD 7750.  My lab only uses linux and we wish to uses these systems to test algorithms using OpenCL.  However, after setting the discrete graphics card as the primary display in the BIOS, installing the AMD Proprietary Catalyst 12.3 linux drivers, and setting the xorg.conf, the screen is corrupted and in the bottom right corner there is a watermark saying "Unsupported Hardware."  I tried setting the integrated graphics card as the primary display in the BIOS and adjusted the xorg.conf file accordingly, but then the screen just goes blank when the login screen should popup.  I tracked the problem to the 7750 graphics card as the system worked perfectly when I removed it.  Since I'm also having trouble with a pair of AMD Radeon HD 7950 in linux (see separate post), I'm starting to wonder if all 7xxx graphics cards are not yet supported in linux.  If that's true, I've got five brand new systems with eight 7xxx graphics cards (we bought some for dual configurations) that are just sitting around collecting dust.  Is there any solution or hotfix to what appears to be a driver problem in CentOS 6.2, Fedora 16, and OpenSUSE 12.1?

4 Replies
Adept II

same problem here with an 7750, Ubuntu 11.10 and Catalyst 12.2 .


Most of the 7XXX series of cards will not get official linux support until Catalyst 12.4. Some will come in 12.3 and some will come in 12.5/12.6.

I naively looked at the Windows driver release notes and assumed the same support carried over to the linux driver.

I'd like to strongly request AMD provide release notes for the linux driver like there are with the Windows drivers.  Something that says what's supported and new features added for each driver release.  Right now the most recent release notes are for 11.x something and don't really give any specific information.


...and when is 12.3 for linux expected?

I found some 8.59 linux drivers, clinfo reports my device but opencl programms dont run.