cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

a_zatvornitskiy
Journeyman III

AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

Here is a brief details about what's going on with my setup. First of all, I've decided to run a Non-X version of `fglrx-core_15.201-0ubuntu1_amd64_UB_14.01.deb` as I interested just only in OpenCL environment.

The problem is: got the `Segmentation fault (core dumped)` after second attempt to bump the `clinfo`. The same behavior true from C code. Looks like a OpenCL environment doesn't work at all. In additional, have found a `[ 499.616434] <6>[fglrx] No ADL handler for Escape code 0x00110020` notice.

I put all related things into gist, Ubuntu 14.04.3 LTS, AMD A10-7870K: `clinfo` throws `Segmentation fault (core dumped)` after second a...

That would be great to know what's wrong with my environment and what exactly causes this issue.

Thanks.

0 Likes
14 Replies
a_zatvornitskiy
Journeyman III

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

0 Likes

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

Hi Aleksey, I've whitelisted you so you can post in any of the developer forums.

0 Likes
a_zatvornitskiy
Journeyman III

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

This is definitely an issue just only for `fglrx-core_15.201-0ubuntu1_amd64_UB_14.01.deb` package. The `fglrx_15.201-0ubuntu1_amd64_UB_14.01.deb` works fine.

My question is still open as I have to figure out how to run server driven computation.

0 Likes
pinform
Staff
Staff

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

Hi!

I've moved this thread to the OpenCL forum -- the experts there should help.

--Prasad

0 Likes
opello
Adept II

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

My solution from the linked thread was to also grab /etc/ati/amdpcsdb.default from the fglrx_*.deb after installing the fglrx-core_*.deb.  It resolved the segfaults for me.

0 Likes
dipak
Staff
Staff

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

Has your issue been resolved? If not, please try the latest 15.11 driver released recently.

Regards,

0 Likes
haahh
Adept II

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

Hi!

After installing the latest drivers radeon-crimson-15.11-15.30.1025 (64-bit Linux) and the latest AMD APP SDK (AMD-APP-SDK-v3.0.130.135-GA-linux64) I have following problems with clinfo:

* /opt/AMDAPPSDK-3.0/bin/x86_64/clinfo fails with segmentation fault.

* /opt/AMDAPPSDK-3.0/bin/x86/clinfo works (it claims that my AMD Radeon R9 380 Series supports OpenCL 1.2, but if I remember correctly OpenCL 2.0 works only for 64-bit).

* /opt/AMDAPPSDK-3.0/bin/x86_64/clinfo starts to work fine after 'unset LD_LIBRARY_PATH' (LD_LIBRARY_PATH=/opt/AMDAPPSDK-3.0/lib/x86_64/). I don't know why that happens.

I'll try go back to AMD-APP-SDK-v3.0.124.132-GA-linux64 and old drivers.

Edit:

* Going back to AMD-APP-SDK-v3.0.124.132-GA-linux64 does not help

* Going back to AMD-Catalyst-15.9-Linux-installer-15.201.1151 helps (with both AMD-APP-SDK-v3.0.124.132-GA-linux64 and AMD-APP-SDK-v3.0.130.135-GA-linux64).

ENV: Linux Mint 17.2, AMD Radeon R9 380 4GB

0 Likes
nibal
Challenger

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

I have also an Ubuntu 14.04 x64 setup. Using almost the latest drivers and SDK, though. A few comments:

|   * /opt/AMDAPPSDK-3.0/bin/x86_64/clinfo fails with segmentation fault.

You should try using the clinfo which comes with your catalyst driver. It is usually more up-to-date than your SDK's.

|    */opt/AMDAPPSDK-3.0/bin/x86/clinfo works (it claims that my AMD Radeon R9 380 Series supports OpenCL 1.2, but if I remember correctly OpenCL 2.0 works only for 64-bit).

What is 64bit? Your OS or your GPU access? i haven't had any problems working my kernels either with x64 OS or 64 bit GPU mode.

|    * /opt/AMDAPPSDK-3.0/bin/x86_64/clinfo starts to work fine after 'unset LD_LIBRARY_PATH' (LD_LIBRARY_PATH=/opt/AMDAPPSDK-3.0/lib/x86_64/). I don't know why that happens.

Yeah, that's because you ran clinfo from the catalyst driver. It is more up-to-date. Search your fs for more clinfo's....

HTH

Nikos

0 Likes
haahh
Adept II

Re: AMD A10-7870K w/ Catalyst 15.9: `clinfo` throws the `Segmentation fault (core dumped)` after second attempt

You should try using the clinfo which comes with your catalyst driver. It is usually more up-to-date than your SDK's.

Thanks. Yeah, you're right, there is one more in /usr/bin/. I will install new driver and try again.

0 Likes