cancel
Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

yousry
Adept I

Accessing OGL with Ubuntu Oneric (64Bit) APP 2.6 + HD4XXX or HD5XXX results in CL_INVALID_GL_OBJECT

Jump to solution

I've searched the forum and didn't find a workable solution.

Does anybody build/have a deb package of APP?

(btw. OpenCL without OGL access works fine.)

0 Likes
1 Solution

Accepted Solutions
nou
Exemplar

Re: Accessing OGL with Ubuntu Oneric (64Bit) APP 2.6 + HD4XXX or HD5XXX results in CL_INVALID_GL_OBJECT

Jump to solution

export LD_LIBRARY_PATH=/usr/lib/fglrx

View solution in original post

4 Replies
nou
Exemplar

Re: Accessing OGL with Ubuntu Oneric (64Bit) APP 2.6 + HD4XXX or HD5XXX results in CL_INVALID_GL_OBJECT

Jump to solution

export LD_LIBRARY_PATH=/usr/lib/fglrx

View solution in original post

yousry
Adept I

Re: Accessing OGL with Ubuntu Oneric (64Bit) APP 2.6 + HD4XXX or HD5XXX results in CL_INVALID_GL_OBJECT

Jump to solution

Thank you.

I added the following lines to my .bashrc

# AMD APP

AMDAPPSDKROOT="/opt/AMDAPP"

LD_LIBRARY_PATH=$LD_LIBRARY_PATH"/opt/AMDAPP/lib/x86_64":"/opt/AMDAPP/lib/x86":"/usr/lib/fglrx"

export AMDAPPSDKROOT

export LD_LIBRARY_PATH

0 Likes
pwvdendr
Adept II

Re: Accessing OGL with Ubuntu Oneric (64Bit) APP 2.6 + HD4XXX or HD5XXX results in CL_INVALID_GL_OBJECT

Jump to solution

LD_LIBRARY_PATH=$LD_LIBRARY_PATH"/opt/AMDAPP/lib/x86_64":"/opt/AMDAPP/lib/x86":"/usr/lib/fglrx"

Just a small detail but you should add an extra : there, I think. Now you lose the current folder in your path.

yousry
Adept I

Re: Accessing OGL with Ubuntu Oneric (64Bit) APP 2.6 + HD4XXX or HD5XXX results in CL_INVALID_GL_OBJECT

Jump to solution

You are right. Thank you.

0 Likes