Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

Access Violation when clGetPlatformIDs is called

I downloaded AMD APP SDK 2.8 for win7 64bit(AMD-APP-SDK-v2.8-Windows-64.exe), and the 9.003 driver for a FirePro W7000 card from AMD website.

When I run the samples from AMD APP SDK using VS 2010, for instance, sample "BoxFIlter", I see "Access Violation message at line #220 in "SDKApplication.cpp" where  clGetPlatformIDs is called.

The code is copied here:

    cl_int status = CL_SUCCESS;

    cl_uint numPlatforms=1;

    cl_platform_id platform = NULL;

    status = clGetPlatformIDs(0, NULL, &numPlatforms); // Access violation here!!!

The message says:

"First-chance exception at 0x00000000 in BoxFilter.exe: 0xC0000005: Access violation.

Unhandled exception at 0x00000000 in BoxFilter.exe: 0xC0000005: Access violation.

The program '[7040] BoxFilter.exe: Native' has exited with code -1073741819 (0xc0000005)."

This happens to other samples as well. I checked the installation, environmental variables, and the driver version. Everything looks good to me. Has anyone seen this before? What could be the problem that causes it?


2 Replies

I experienced the same syndrome (accessv at 00000000 in the first opencl.dll call) when I uninstalled the latest catalyst and then, after a reset, I installed an older catalyst. Then the opencl.dll was broken.

The solution was:

a) install the latest cat

b) use the AMD Catalyst Uninstall utility right after the regular uninstall. This way older drivers can function well.


Just try realhet's approach for now. FYI, there was a similar issue with W8000 card sometime back, and now it is W7000 card. Both the issues were with 9.003 driver. But an older driver worked for that person. I will let you know if there is any thing more to share.