Showing results for 
Search instead for 
Did you mean: 

Archives Discussions

Journeyman III

7970m are they flawed or is it driver support?

Ok Please do not direct me me to any other help forum and what not..

Id like my answer here...

Ok the recent release of the 7970m has seen nothing but error after error and complaint after complaint..

99% of user report that the 7970m is ether flawed or the drivers are bad..

I own a 7970m xfire note book and i can say that there is some thing really wrong with ether the card or the drivers..

are there any devs here that work with amd drivers and can you tell me what is going on with the cards or the drivers?

thank you and if any one can help me out with this that would be great..

7 Replies


I completely understand your frustration with all of the AMD forums. It's really hard to keep them straight. (Please know we are working on improving the different forums and making it easier to know what to post where.)

Please know that this is the software developers forum. The kinds of questions that are typically asked and answered here are code optimization and tool questions.

The best places to get answers for your Catalyst questions are those 3 standard places that as you point out that I always refer Catalyst questions to.




digitalfubar wrote:

i can say that there is some thing really wrong with ether the card or the drivers..

Can you say what is wrong exactly?

Journeyman III

well every thing.. xfire is completely broken and when you call support they pawn it off onto the manufacturer of your comp wich for me is dell.. but this is a universal problem between all company's and makes of laptops that run these cards at the moment..

the reason i asked here was in the hopes of getting a person or persons that work for amd making these drivers might respond..

im finding that for these new cards that the 69xxm drivers were used and modified..  and not a completely new driver made even tho the hardware is different in every way.. and the way its addressed and address systems and programs..

the cards do not hold 3D voltage and rarely does the 3D full screen voltage kick in.. and when it does it errors out almost immediately..

now ive been looking for the tools to be able to decompile and pack my own drivers so i could paly with these and see if i can some what figure out further whats going on..

so if any one can point me in the right direction that would be great.. also is there a program that will test the driver and the card compatibility? a diagnostics of sorts for amd gpus?


I dont even know which driver you are using (since you didnt mention any versions).

Did you try the latest 12.6 and 12.7 drivers?

You might want to try these too:


IM SORRY Im on 12.7beta.. ive tried every thing from 12.5beta.. to 12.7..

there all the same with the same errors and what not.. and if you look a tthe versions of them they look like there from the 69xxm series..  

any ideas on any of the programs im looking for?   and if there is a diagnostic tool for amd gpus?

also there claiming to have fixed problems with these drivers.. but in reality they have not.. xfire DOES NOT WORK..

and your lucky if your single gpu(not in xfire) will work correctly..

but as i said this a brod problem that has yet to be addressed by amd./ati  and since now 2 months later its still not fixed i want to decompile the driver and see what i can see and recopile it.. 

so i guess what im wanting to know is this..

1. what would i need software wise to do this? dlls and all.. open em up compare.. and put it back together..

2. is there a diagnostic program for amd gpus to test just there functionality?



Probably while you were writing, Dell just released new 'official' drivers for the 7970m.

The release date seems to be July 13, today.

You can google something like "Dell releases official 7970m drivers".

I did see a comment that until now many 7970m manufacturers have been kludging their own

driver packages, which has lead to many problems.

Hope it helps.


yea i got them but my device id is not written in to the driver and when i mod the inf file it still doesnt work lol..

thanks tho for the reply..