2 Replies Latest reply on Dec 28, 2017 1:06 PM by ray_m

    Can't install drivers -- installation keeps failing. Help?


      Okay, so I've got a desktop PC running an R9 390X GPU (other specs listed at the end). I haven't had access to it for a couple of months, but coming back to it, I found that there was an unfamiliar stutter to every game that used the GPU. Certain low-graphics games like Rogue Legacy still ran smoothly, but everything else would just skip awkwardly once every few seconds, freezing and taking a moment to catch up. It made most games unplayable, and these were all games that had played perfectly smoothly on this system before. I figured it might be a driver issue, so I ran the AMD Driver Autodetect tool to see if I could update my drivers.


      It told me that there were optional newer drivers available (17.1.1 to 17.12.2), so I tried to run the update -- but it failed. Every time I try, a box comes up that says "AMD Software has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available." Hmm. How specific. Just in case this was an issue with the Autodetect tool, I tried downloading the relevant drivers package directly (win10-64bit-radeon-software-adrenalin-edition-17.12.2-dec19) and installing it locally, but the same error message came up. I read around on the internet, and various people suggested that the problem in these sorts of situations is often the previous driver hanging around and making problems for the new one, so I downloaded Display Driver Uninstaller and got rid of my current GPU driver completely. I then attempt to install the new ones again, but got that same vague "AMD Software has stopped working" error message. I tried installing them in safe mode, but got the same thing. So I don't have a GPU driver at all, and am still being prevented from installing any.


      Following the suggestions of some more internet folks, I tried running the System File Checker tool, which told me that "Windows Resource Protection found corrupt files but was unable to fix some of them." Okay, I thought, this sounds promising. When you get this error message, the next step the internet recommends is to run DISM cleanup ("DISM /Online /Cleanup-Image /RestoreHealth" in an elevated command prompt) ... but unfortunately that hasn't worked either. It progresses to 98.8%, and then just hangs there. I'm not being impatient with this -- I left it running all night, and it's been on 98.8% for more than 13 hours now. Based on my googling, this seems to be kind of unusual. Lots of other people have described their DISM cleanup process hanging at 20%, or 40%, but I can't find anyone else who's said this happened to them at 98.8%. The advice people give to those other folks is generally to just be patient, it can take a few hours, etc ... but like I said: 13+ hours. I've also tried the SFC scan in safe mode (which yielded the same result) and the DISM Cleanup in safe mode (which yielded a slightly different variant: it got to 98.8%, then aborted the operation saying that it failed to download something -- which is not unreasonable, given that the PC had no internet connection while in that standard form of safe mode).


      I'm at a bit of a loss as to what to do next. The DISM Cleanup seems to be necessary to get the SFC scan to work, and the SFC scan seems to be necessary to get the driver installation to work. But none of it can happen if I'm just gonna hang at 98.8% for the rest of my natural life. I just wanted my games to stop stuttering, but now I'm driverless and seemingly unable to ever install any new ones. Can anyone help?


      System specs:


      GPU: Sapphire AMD R9 390x 8gb

      OS: Windows 10 64bit

      Driver version installed: had been 17.7.1, currently none (well, when I run driver installation it says "17.50.02 partially installed")

      Display: Philips 279X6QJSW 1920x1080 @60Hz DisplayPort

      Motherboard: MSI Z270i Gaming Pro Carbon AC LGA 1151

      CPU: i5 6600K

      Power Supply: Coolermaster V750 750w 80+ Gold

        • Re: Can't install drivers -- installation keeps failing. Help?

          For the reference of anyone in the future who comes across this page because you have the same problem: I had to do a System Restore, but I eventually solved it.


          At first, like everything else, System Restore wasn't working. It would come up as "System Restore failed while restoring the directory from the restore point" and gave the error code, "An unspecified error occurred during System Restore. (0x80070091.)" All I had to do was follow the instructions in this YouTube video: FIX System Restore Error 0x80070091 in Windows 10 - WORKS 100%! - YouTube


          Then, after making sure that my Windows Defender protection was 100% turned off, I was able to do a System Restore that actually finished. The earliest point I could restore to was from a month ago, but that was enough to solve my graphics issues. If you're facing the same problem, I'd recommend that you run a full Windows Defender scan as soon as the System Restore is finished. (Plus, if you ever downloaded CCleaner, make sure it's totally uninstalled from your computer.) System Restore is actually a much less stressful option that I assumed it would be. I had to redownload Chrome and a few other programs, but otherwise, it left all my files intact.


          Hope this fix works for you as well.

          • Re: Can't install drivers -- installation keeps failing. Help?

            MODERATOR NOTE:  I am glad to see you have resolved your issue. To help keep this post on topic and help other with a similar issue, I am locking this thread.