3 Replies Latest reply on Nov 23, 2017 10:34 AM by amdmatt

    Ryzen 7 1700 segfault



           I recently bought a Ryzen 7 1700 and it has the linux segfault issue. I bought it from a local store in India and the import date is 03/2017 so it seems to be pre week 25 batch that are reportedly affected by this issue.I ran the compilation on Ubuntu through VMWare.


      It usually throws the segfaults within a minute or two when all the threads are being used.


      Please find my current configuration:


      CPU : AMD Ryzen 7 1700 (Stock Vcore and Soc)

      RAM: ADATA 2800 MHZ (AX4U280038G17) - Running this at 2666 mhz (This was out of the box configuration in Motherboard).Did not enable XMP. Currently using single 8GB stick.

      Storage: Samsung 850 Evo 250GB

      Cooler: Corsair H80i ( Temps do not exceed 60c when i run Prime95)

      GPU: Gigabyte GTX 660 OC

      OS : Windows 10/ Ubuntu 17.10 ( kernel-4.14 )


      Although, I did not experience much issues in Windows 10, I do not want to be stuck with a faulty processor and AMD has been quiet on whether this is a hardware or a software issue.

      If it is a software issue I'd be happy to stick with my current processor otherwise please let me know how to proceed with an RMA. I am based in Hyderabad, India.