Vega FE: 2 Gaming Drivers, both terrible.

Discussion created by neruok on Nov 4, 2017
Latest reply on Nov 6, 2017 by andreelijah

This may be related to this other post as I've run across this issue trying to fix it.

Vega FE 17.Q4 Driver Options missing


After installing the 17.Q4 driver I went to switch to the gaming driver to play Destiny 2. The gaming drivers didn't work well at all. 15 fps in loading screens and 5 fps in game at low settings 25% render resolution.


I decided to use the firepro drivers since they worked well with the game and gave me good fps. They worked just fine 200+ fps in menus and 60 fps in game at high settings at 4k.


After switching to the firepro drivers it worked just fine 200+ in menus and 60 at high settings 4k. I've figured I'd be fine if I just kept using the firepro drivers, but there's a game crashing bug in the campaign. It was fixed with newer releases of the gaming driver. But the gaming driver just doesn't work.


This bug is preventing me from switching back to the firepro drivers without reinstalling and the gaming drivers don't perform well at all. Radeon settings still works if I switch to the gaming drivers, but the pro drivers don't show up in the menu afterwards. The menu is still there, but it only gives me the option of 2 gaming drivers, both of which work poorly in any game I play.