AnsweredAssumed Answered

clinfo crashes with Vega Frontier Edition

Question asked by pdxtabs on Jul 14, 2017
Latest reply on Jul 26, 2017 by jedwards

Hello,

 

I just got an AMD Vega Frontier Edition, which is my first AMD OpenCL enabled card. As such, I sort of don't know what I am doing. I performed the following actions:

 

  1. Installed a fresh copy of Ubuntu 16.04.2 with all updates, rebooted.
  2. Installed "Radeon Vega Frontier Edition for Ubuntu 16.04.2 17.6" driver (amdgpu-pro-17.20-445420.tar.xz), rebooted.
  3. Installed APP-SDK 3.0.130 (AMD-APP-SDKInstaller-v3.0.130.136-GA-linux64.tar.bz2), rebooted.

 

However, when I run clinfo (or sudo clinfo) it crashes:

$ sudo clinfo

terminate called after throwing an instance of 'cl::Error'

  what():  clGetPlatformIDs

Aborted (core dumped)

 

Did I miss a step?

 

My system is as follows:

  • AMD Graphics Card
    • AMD Graphics Card: Vega Frontier Edition
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Ubuntu 16.04.2, with all updates
  • Driver version installed
    • "Radeon Vega Frontier Edition for Ubuntu 16.04.2 17.6" driver (amdgpu-pro-17.20-445420.tar.xz)
  • Display Devices
    • Dell U2413f, DVI (with adapter from Frontier Edition box), 1920x1200 @ 60Hz
  • Motherboard + Bios Revision
    • MSI B75MA-P45 BIOS 1.9 (latest)
  • CPU/APU
    • Intel i5-3470
  • Power Supply Unit  Make, Model & Wattage
    • EVGA SuperNOVA 1000 G2
  • RAM
    • 8GB

I have attached a full dmesg, strace of clinfo, and the coredump of clinfo.

 

Message was edited by: Tabor Kelly Adding strace.

Attachments

Outcomes