Multiple problems with 17.6.2 driver update

Discussion created by lordlevis on Jun 18, 2017
Latest reply on Aug 13, 2017 by rebelyell



Ever since I re-formatted my windows 8.1 (I've been having driver update problems, that wouldn't want to upgrade to the newest one), I've been having multiple problems. First off for my specs, here are attached the MSinfo32, and DxDiag info. I'm using an MSI all in one pc AG2712a-025US model from 2013 that I bought. I have 8gb of ram, and for the display drivers I have the Intel graphics 4000 and ATI Radeon HD8970m.



So, ever since the reformatting of my windows 8.1, I've reinstalled the updates and all, everything went fine. For the exception of two stuff (And believe me, I went to a pc repair guy, microsoft tech support, and ubisoft tech support, and they all failed me, with ubisoft saying that i might need to change my ram sticks): I could play GTA V before my reformat of windows 8.31, and also Rainbow Six Siege (see attached for error codes and all). Now it just simply refuses to work. Before, everything worked fine, even though Amd Gaming Evolved was stuck with a driver update that had the 13.something version on it.


Now with the reformat, even though those two games seem to refuse to work, my contextual menu (see attached), with the new 17.6.2 update, when it installed it, the option to restart my computer froze, had to force close it, restarted my computer, and the contextual menu option "Radeon graphics settings'' just simply dissapeared.

Even Ccleaner refuses to acknowledge my Amd Radeon HD8970m graphics card. And before my reformat, it acknowledged it just fine.


At Microsoft tech support and Ubisoft tech support, they tried the following: replacing some .dll files related to Directx (apparently everything works fine even though the error code from R6 suggested a problem there), reinstalled .net framework, reinstalled microsoft visual c++, reinstalled my AMD graphics driver from scratch. And in the end, Ubisoft suggest i use memtest86+ to test my Ram, or completely replace my ram sticks because supposedly Rainbow six has problems accessing the memory?... (Even though these two games worked fine? before my reboot of windows 8.1)


So right now, me and my friend think that since it worked before when it recognized my graphics card, the new updates on the driver somehow isn't working and that might be the problem. That the games want to run on the Intel integrated graphics 4000 instead of AMD Radeon HD8970m. I tried changing the power options to high performance and all, but no result.


Anyone got any tips on how to make my computer recognize properly the graphics card (like, that even Ccleaner recognizes it?)