AnsweredAssumed Answered

Problems with driver after update in Linux

Question asked by teruksor on Jan 26, 2017
Latest reply on Jan 27, 2017 by teruksor

Hello I'm having a little bit of a nasty problem right now. I have an APU A10-7850K and I've been using Scientific Linux 7.2 which is based on Red Had Enterprise 7.2 for over a year now with the latest AMD driver for that platform  Crimson 15.12  and it was working fine. Regularly, I don't update the kernel or xorg to avoid problems with the graphic drivers, but today I updated my system without noticing that as Red Hat the whole system has been updated to the version 7.3. The first run after the reboot I could enter the desktop but the graphics weren't working well, so I decided to reinstall the drivers, I ran aticonfig --uninstall but returned a long list of files not found in the folder /lib/modules/fglrx/build_mod/.

I rebooted my PC with the default basic video support that comes with the OS but something seems corrupted because after everything loads and the X server is about to start I get a completely black screen again but the PC is not responding, and I can't use ctrl-alt-F3 to use the terminal or anything, so i have to hard reset. Back in Grub I started my PC with runlevel 3 and tried to reinstall the drivers, it tells me it's successful at the end but it says "/usr/libexec/plymouth/plymouth-populate-initrd_ line 233 (line 234 and 235) dfatal: command not found" several times. ran aticonfig --initial and doesn't give me any error I reboot the system once more this time the PC doesn't hang, because I can see the cursor but the rest is completely black, I can enter my username and password blindly but I can't see anything else.


What is driving me crazy right now is that I had that issue before and it had a really simple solution but I can't remember exactly what I did, it was something that wasn't uninstalled properly then I could boot again the PC with the default video support, generate the rpm file install it and that's it. But I just can't remember what was causing the problem or how to fix it. After I uninstall I ran lsmod

| grep fglrx but I have no results, also I delete the xorg.conf file generated by aticonfig  So I'm clueless about what to do now, and of course I want to avoid having to reinstall the whole system or something extreme like that because I have a lot of work related information there and custom software and configurations that would take me a lot of time to recover.